aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-03-30 08:25:02 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-30 21:23:55 +0100
commit7b4b8a2481ce256e35fb86ebdeb944ee29ad5231 (patch)
treea92d45f973ed47fb84aac387ad08d6907837f8fc /meta/recipes-kernel/linux/linux-yocto_4.1.bb
parent4dd3bd968042d943f279d91d220abc61ebd574a5 (diff)
downloadopenembedded-core-contrib-7b4b8a2481ce256e35fb86ebdeb944ee29ad5231.tar.gz
linux-yocto/4.1: i2c: designware: Backport i2c patches
To enable Apollo Lake/Broxton, we backport the following changes: da451824f75f i2c: designware: Convert to use unified device property API 58b1b5365f4a i2c: designware: Do not require clock when SSCN and FFCN are provided 8995091cfa0f i2c: designware: retry transfer on transient failure 1fc62907f84e i2c: designware: Move common probe code into i2c_dw_probe() 678110c0f2b8 i2c: designware: Rename platform driver probe and PM functions c51c2e104d40 i2c: designware: Make dw_readl() and dw_writel() static 98d2b6e244ad i2c: designware: Remove unused functions 3d04c6e99652 i2c: designware: Disable interrupts before requesting PCI device interrupt fb5b7be0fbe7 i2c: designware: Remove interrupt clearing from i2c_dw_pci_probe() d48fd08b11c8 i2c: designware: Make debug print in i2c_dw_isr() shorter 28f94bc07450 i2c: designware-pci: use IRQF_COND_SUSPEND flag 95f494846fc1 i2c: designware: Avoid unnecessary resuming during system suspend fb2ae3705a3a i2c: dw: Add APM X-Gene ACPI I2C device support 516a0fc91e00 i2c: designware: Add support for AMD Seattle I2C 874d63b3c95c i2c: designware: fix IO timeout issue for AMD controller 47543e80c6dd i2c: designware: reverts "i2c: designware: Add support for AMD I2C controller" 076fe383c4b5 i2c: designware: use to_pci_dev() Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index 01708ddcc5..87baa625b6 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "1582fc5caa4957ef6a1349c0ae4178c2846c1af1"
-SRCREV_machine_qemuarm64 ?= "630b726098c95111a41336de04a5b7e201b012e9"
-SRCREV_machine_qemumips ?= "9406ef8745f90c401e3551f45e2945d1f7408327"
-SRCREV_machine_qemuppc ?= "630b726098c95111a41336de04a5b7e201b012e9"
-SRCREV_machine_qemux86 ?= "630b726098c95111a41336de04a5b7e201b012e9"
-SRCREV_machine_qemux86-64 ?= "630b726098c95111a41336de04a5b7e201b012e9"
-SRCREV_machine_qemumips64 ?= "c29ac79ffc2957612e789ac7a5fe4919f99bf99f"
-SRCREV_machine ?= "630b726098c95111a41336de04a5b7e201b012e9"
+SRCREV_machine_qemuarm ?= "196e7ddacccbf85cc05123f40a2235ac5e7ffa38"
+SRCREV_machine_qemuarm64 ?= "da451824f75f47a44203c63bed245c8ead8f5fcd"
+SRCREV_machine_qemumips ?= "4fafbdad6385ca1ba8bd3ac98a607a0b11af4a4b"
+SRCREV_machine_qemuppc ?= "da451824f75f47a44203c63bed245c8ead8f5fcd"
+SRCREV_machine_qemux86 ?= "da451824f75f47a44203c63bed245c8ead8f5fcd"
+SRCREV_machine_qemux86-64 ?= "da451824f75f47a44203c63bed245c8ead8f5fcd"
+SRCREV_machine_qemumips64 ?= "4a22137cfe0ed14f15e1ddbae1064959f2e512bc"
+SRCREV_machine ?= "da451824f75f47a44203c63bed245c8ead8f5fcd"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \