aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-12-08 08:57:48 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-08 17:22:21 +0000
commit04b22b6b4953360ea383c4d928dea66f7b1796e6 (patch)
treec47dafba5948ab0ab60885b465d8dce66bacee91 /meta/recipes-kernel/linux/linux-yocto_4.1.bb
parent5175d9a6955c1783fc35ab6832b6be4cbb9fc01b (diff)
downloadopenembedded-core-contrib-04b22b6b4953360ea383c4d928dea66f7b1796e6.tar.gz
linux-yocto/4.1: Fix kernel oops on qemuarm boot
Backporting two mainline commits to address kernel oops: Internal error: Oops: 17 [#1] PREEMPT ARM Modules linked in: CPU: 0 PID: 42 Comm: jbd2/vda-8 Not tainted 4.1.8-yocto-standard #1 Hardware name: ARM-Versatile PB task: c7223300 ti: c725e000 task.ti: c725e000 PC is at blk_mq_tag_to_rq+0x24/0x78 LR is at bt_for_each+0x70/0xc4 pc : [<c0364458>] lr : [<c0368118>] psr: 20000113 sp : c725fa18 ip : c725fa30 fp : c725fa2c r10: c0365ce0 r9 : 00000020 r8 : c7104200 r7 : c70ee5ac r6 : 00000001 r5 : 00000021 r4 : c7122da0 r3 : c7104000 r2 : 00000000 r1 : 00000021 r0 : 00000000 Flags: nzCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment kernel Control: 00093177 Table: 072f4000 DAC: 00000017 Process jbd2/vda-8 (pid: 42, stack limit = 0xc725e190) Stack: (0xc725fa18 to 0xc7260000) [YOCTO #8663] Signed-off-by: Alimon Limon <anibal.limon@linux.intel.com Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index 9553f3d2a7..776620261f 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "817a421e7c1be9c1136da5772f351e77513a1ed2"
-SRCREV_machine_qemuarm64 ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
-SRCREV_machine_qemumips ?= "9f244d964a5910244fc82c261c48e1dc0862654b"
-SRCREV_machine_qemuppc ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
-SRCREV_machine_qemux86 ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
-SRCREV_machine_qemux86-64 ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
-SRCREV_machine_qemumips64 ?= "7fdfaf2387d7896c1ead6a000616e01ce72f0764"
-SRCREV_machine ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
+SRCREV_machine_qemuarm ?= "2494184ad34764bdfa1bfd9a57eabfb34d170c0e"
+SRCREV_machine_qemuarm64 ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
+SRCREV_machine_qemumips ?= "85a76c24f5aaa99618fdb15d5f3966a2e03cd572"
+SRCREV_machine_qemuppc ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
+SRCREV_machine_qemux86 ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
+SRCREV_machine_qemux86-64 ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
+SRCREV_machine_qemumips64 ?= "79181dc5284d9831d240d7ba58a2b574f6528b90"
+SRCREV_machine ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
SRCREV_meta ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \