aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2013-12-10 16:58:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-10 11:29:54 +0000
commite5d81f757de4bd1bfd37a96300edd50b77b0d21c (patch)
treedc38d964ea9976412de63a559d5ca2bbac55771d /meta/recipes-kernel/linux/linux-yocto
parenta01febdeacd08c7ab7983ad7555368a17b937907 (diff)
downloadopenembedded-core-contrib-e5d81f757de4bd1bfd37a96300edd50b77b0d21c.tar.gz
meta/*: remove unnecessary patches
The following patches are found, but not used by any recipe, so we should remove them. meta/recipes-connectivity/avahi/files/fix_for_automake_1.11.2.patch meta/recipes-connectivity/dhcp/dhcp/fix-client-path.patch meta/recipes-connectivity/libnss-mdns/files/alignment-fix.patch meta/recipes-core/dbus/dbus-1.6.10/test-run-path.patch meta/recipes-core/gettext/gettext-0.16.1/fixchicken.patch meta/recipes-core/gettext/gettext-0.16.1/getline.m4.patch meta/recipes-core/systemd/systemd/use-rootlibdir.patch meta/recipes-core/util-linux/util-linux/remove-lscpu.patch meta/recipes-core/util-linux/util-linux/remove_sigsetmark.patch meta/recipes-core/util-linux/util-linux/uclibc-compile.patch meta/recipes-devtools/autoconf/autoconf/autoconf-x.patch meta/recipes-devtools/btrfs-tools/btrfs-tools/btrfs-progs-fix-parallel-build.patch meta/recipes-devtools/btrfs-tools/btrfs-tools/btrfs-progs-fix-parallel-build2.patch meta/recipes-devtools/cdrtools/cdrtools-native/no_usr_src.patch meta/recipes-devtools/elfutils/elfutils-0.155/elfutils-robustify.patch meta/recipes-devtools/gdb/gdb/libiberty-cross.patch meta/recipes-devtools/perl/perl-5.14.3/asm-pageh-fix.patch meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch meta/recipes-devtools/python/python-pygobject/generate-constants.patch meta/recipes-devtools/qemu/files/3f08ffb4a4741d147634761dc053ed386243a0de.patch meta/recipes-devtools/qemu/files/enable-i386-linux-user.patch meta/recipes-devtools/qemu/files/init-info.patch meta/recipes-devtools/rpm/rpm/rpm_fix_for_automake-1.12.patch meta/recipes-devtools/tcf-agent/tcf-agent/fix_tcf-agent.init.patch meta/recipes-extended/iputils/files/arping-break-libsysfs-dependency.patch meta/recipes-extended/libarchive/libarchive/0003-Patch-from-upstream-rev-2516.patch meta/recipes-extended/procps/procps-3.2.8/pagesz-not-constant.patch meta/recipes-gnome/gtk+/gtk+-2.24.22/no-demos.patch meta/recipes-gnome/libglade/libglade-2.6.4/no-deprecation.patch meta/recipes-graphics/mesa/mesa/0005-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch meta/recipes-graphics/xorg-lib/libxxf86dga/libxxf86dga-1.1.3_fix_for_x32.patch meta/recipes-kernel/kmod/kmod/fix-undefined-O_CLOEXEC.patch meta/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch meta/recipes-support/gnutls/gnutls/gnutls-texinfo-euro.patch meta/recipes-support/nspr/nspr/fix-build-on-aarch64.patch [YOCTO #5180] Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch b/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch
deleted file mode 100644
index d07335a5f7..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: tools/perf/Makefile
-===================================================================
---- a/tools/perf/Makefile 2011-01-14 14:17:33.127008554 -0600
-+++ b/tools/perf/Makefile 2011-01-14 14:18:14.227008548 -0600
-@@ -588,42 +588,8 @@
- endif
- endif
-
--ifdef NO_LIBPERL
-- BASIC_CFLAGS += -DNO_LIBPERL
--else
-- PERL_EMBED_LDOPTS = $(shell perl -MExtUtils::Embed -e ldopts 2>/dev/null)
-- PERL_EMBED_LDFLAGS = $(call strip-libs,$(PERL_EMBED_LDOPTS))
-- PERL_EMBED_LIBADD = $(call grep-libs,$(PERL_EMBED_LDOPTS))
-- PERL_EMBED_CCOPTS = `perl -MExtUtils::Embed -e ccopts 2>/dev/null`
-- FLAGS_PERL_EMBED=$(PERL_EMBED_CCOPTS) $(PERL_EMBED_LDOPTS)
--
-- ifneq ($(call try-cc,$(SOURCE_PERL_EMBED),$(FLAGS_PERL_EMBED)),y)
-- BASIC_CFLAGS += -DNO_LIBPERL
-- else
-- ALL_LDFLAGS += $(PERL_EMBED_LDFLAGS)
-- EXTLIBS += $(PERL_EMBED_LIBADD)
-- LIB_OBJS += $(OUTPUT)util/scripting-engines/trace-event-perl.o
-- LIB_OBJS += $(OUTPUT)scripts/perl/Perf-Trace-Util/Context.o
-- endif
--endif
--
--ifdef NO_LIBPYTHON
-- BASIC_CFLAGS += -DNO_LIBPYTHON
--else
-- PYTHON_EMBED_LDOPTS = $(shell python-config --ldflags 2>/dev/null)
-- PYTHON_EMBED_LDFLAGS = $(call strip-libs,$(PYTHON_EMBED_LDOPTS))
-- PYTHON_EMBED_LIBADD = $(call grep-libs,$(PYTHON_EMBED_LDOPTS))
-- PYTHON_EMBED_CCOPTS = `python-config --cflags 2>/dev/null`
-- FLAGS_PYTHON_EMBED=$(PYTHON_EMBED_CCOPTS) $(PYTHON_EMBED_LDOPTS)
-- ifneq ($(call try-cc,$(SOURCE_PYTHON_EMBED),$(FLAGS_PYTHON_EMBED)),y)
-- BASIC_CFLAGS += -DNO_LIBPYTHON
-- else
-- ALL_LDFLAGS += $(PYTHON_EMBED_LDFLAGS)
-- EXTLIBS += $(PYTHON_EMBED_LIBADD)
-- LIB_OBJS += $(OUTPUT)util/scripting-engines/trace-event-python.o
-- LIB_OBJS += $(OUTPUT)scripts/python/Perf-Trace-Util/Context.o
-- endif
--endif
-+BASIC_CFLAGS += -DNO_LIBPERL
-+BASIC_CFLAGS += -DNO_LIBPYTHON
-
- ifdef NO_DEMANGLE
- BASIC_CFLAGS += -DNO_DEMANGLE