summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-28 17:14:08 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-03 00:09:59 +0000
commit2c2bdd9661e4341178f2d831bb56e961e74e8509 (patch)
tree6c3cabc371623851fc9f096bd5792eb9e35e8390 /meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
parent0c58c479af151969dfb84d8763696da657f7248d (diff)
downloadopenembedded-core-contrib-2c2bdd9661e4341178f2d831bb56e961e74e8509.tar.gz
linux-yocto: introduce 5.4 recipes
This creates recipes for the v5.4/* branches of the linux-yocto reference kernel. preempt-rt, yaffs2, aufs5 and reference board specific patches are part of these branches. All major architectures: x86,x86-64,ARM, ARM64,ppc,mips and mips64 have been feature tested against this reference. 5.4 is a LTS release, and as such will receive -stable updates for the duration of upstream korg support. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
new file mode 100644
index 0000000000..a028b37548
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
@@ -0,0 +1,32 @@
+KBRANCH ?= "v5.4/standard/tiny/base"
+KBRANCH_qemuarm ?= "v5.4/standard/tiny/arm-versatile-926ejs"
+
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "5.4.15"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine_qemuarm ?= "9eeafafc19278b5c5376ba1fd9eae26626730458"
+SRCREV_machine ?= "cdda35317561d2741b396efa623ace0bd2212c16"
+SRCREV_meta ?= "a48522779fae4887c47268e5f650bf10c94a165c"
+
+PV = "5.4.15"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
+
+# Functionality flags
+KERNEL_FEATURES = ""
+
+KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb"