aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-01-11 11:58:26 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-17 11:32:16 +0000
commit2dbc788bc3988532f0932e8e51e24ba702c28f6a (patch)
treec9a87cd8bc44ae51bbb882f4ee281855cfbb026a /meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
parenta1f235ad736d322bb50eb4a4293b6b2f4e5200aa (diff)
downloadopenembedded-core-contrib-2dbc788bc3988532f0932e8e51e24ba702c28f6a.tar.gz
linux-yocto: introduce v4.4 standard/preempt-rt/standard kernel
The 4.4 kernel has been under test via linux-yocto-dev, and is the next LTS/LTSI kernel. So we take our -dev support and created a named/versioned recipe for use in upcoming releases. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
new file mode 100644
index 0000000000..d348c0a628
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
@@ -0,0 +1,23 @@
+KBRANCH ?= "standard/tiny/base"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "4.4"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine ?= "2dadc3524fcbce0c46f5db65b7c20c673fc60503"
+SRCREV_meta ?= "ad9d3f01300ba350563e17db00b2518302e172f6"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""