aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-02-06 11:21:52 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-09 14:31:59 +0000
commit04254d4cc9e6399afd027727864e237cb8006d6d (patch)
tree1b738ac5f2d4921754b3595aa6b5d413ff50d744 /meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
parent230890227304e27acd074a3c748812d7a603d511 (diff)
downloadopenembedded-core-contrib-04254d4cc9e6399afd027727864e237cb8006d6d.tar.gz
linux-yocto: introduce 4.14 recipes
This commit makes the 4.14 kernel available for use with the Yocto configuration fragments and qemu* BSPs. It has been tested for x86,arm,mips and powerpc against the lsb, core* and glibc/mulsc test matrix. This will serve as the LTS kernel in master, with others being removed in subsequent commits. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
new file mode 100644
index 0000000000..bf4b0ac4f6
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
@@ -0,0 +1,25 @@
+KBRANCH ?= "v4.14/standard/tiny/common-pc"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "4.14.16"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine ?= "ae0fb21fdde3df106d7dad76620bdf39721425e2"
+SRCREV_meta ?= "0e964663a7978bdb459c28f3777e1b6dfe97d93d"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "qemux86|qemux86-64"
+
+# Functionality flags
+KERNEL_FEATURES = ""
+
+KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"