summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-08-21 11:44:40 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-22 15:13:51 +0100
commit92642acd1166b7990fb520337b78a4d37ce7cbe4 (patch)
tree10a67b41939cf31ad31998ed4244845e9a76ee9d /meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
parentf9fc16e1776452d3f0c4d6dd8f8eece66722128a (diff)
downloadopenembedded-core-contrib-92642acd1166b7990fb520337b78a4d37ce7cbe4.tar.gz
linux-yocto/6.1: fix uninitialized read in nohz_full/isolcpus setup
Integrating the following commit(s) to linux-yocto/6.1: 4675ec8d0b9a kernel/sched: Fix uninitialized read in nohz_full/isolcpus setup The carry forward of commit from the v5.15 linux-yocto kernel: https://git.yoctoproject.org/linux-yocto/commit/?id=97c96388922 ...in which case the sanity checks are properly *after* the allocation and processing of the bootargs into the cpumask. However, it seems patch (or wiggle?) apparently decided to put the sanity checks *before* the population of the cpumask during the carry-forward and generation of the new v6.1 kernel. Meaning they are validating uninitialized memory and hence nohz_full= and isolcpus= are subject to random failures even for valid input ranges. (From OE-Core rev: 4b349ee66eab8ebe3150ac4c1b449ea5c264a5be) Signed-off-by: Adrian Cinal <adriancinal1@gmail.com> Acked-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
index 8e59cf937e..7b410df847 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
@@ -14,8 +14,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "0aa0b7396b5cbfccd69d23b07e095e4c4fa20589"
-SRCREV_meta ?= "8da434f09dc2892d8ec26325f0856aabccc17bed"
+SRCREV_machine ?= "57eb889d204238845f238b44db6affe64480b958"
+SRCREV_meta ?= "2e1a81f17434de2a9bd27676efdde7861946582e"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https"