summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-10-08 10:26:29 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-08 20:47:52 +0100
commit55a54aed27ffa94a235da526a39aeea59caa3417 (patch)
tree655fe22d3109b7d642e7ba232b5b61785dd642e8 /meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
parentaba70cbbc1ef6139aad862160427eb70faafda84 (diff)
downloadopenembedded-core-contrib-55a54aed27ffa94a235da526a39aeea59caa3417.tar.gz
linux-yocto/5.2: fix strace/ptrace long runtime issues
Bumping SRCREVs to pickup the following kernel commit: [ Author: Bruce Ashfield <bruce.ashfield@gmail.com> Date: Tue Oct 8 13:15:46 2019 +0000 signal/ptrace: fix cgroup2/freezer long runtimes As reported in the thread: https://lkml.org/lkml/2019/10/1/789, in kernels with commit 76f969e8948d82 [cgroup: cgroup v2 freezer], we were seeing much longer runtime in strace/ptrace tests (4 minutes versus 4 seconds). The issue only manifests if CONFIG_PREEMPT is enabled, which is in all of the default configurations. As sugggested in the thread, the movement of preempt_enable_no_resched() until after the cgroup is frozen returns the behaviour to pre-5.2 runtimes. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> ] With this change in place, our times are back to normal: root@qemux86-64:~# cd /usr/lib/strace/ptest/tests root@qemux86-64:/usr/lib/strace/ptest/tests# time ../strace -o log -qq -esignal=none -e/clock ./printpath-umovestr>ttt real 0m3.909s user 0m0.534s sys 0m3.342s This will eventually loop around via -stable, or may need future tweaks, but it does address the immediate issue/symptom that we are seeing, with no obvious side effects. [YOCTO #13556] Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
index acae24edb1..e3fe54441f 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "90a5890111ca601af1cfba50939d4003fa8d9ce8"
-SRCREV_meta ?= "56f5bc749e5a8e40b55a3819288ac277813ec5ef"
+SRCREV_machine ?= "0a9f6ee2443b54c614107728ca76485916010023"
+SRCREV_meta ?= "b867b78b5019ae455af97dec7794cff7527d7624"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.2;destsuffix=${KMETA}"