aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2016-04-29 19:46:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-22 16:09:22 +0100
commit048c901fc32a1fd9a6c4b6f68f618101dfdf94ad (patch)
treeb752db1ce80e7fd57945d6807af619a76ce740f5 /meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
parentb6c71616e66708bb1c456b83f98913b198f49a4a (diff)
downloadopenembedded-core-contrib-048c901fc32a1fd9a6c4b6f68f618101dfdf94ad.tar.gz
linux-yocto-rt, core-image-rt*: Explicitly skip when PREFERRED_PROVIDER_virtual/kernel isn't set to linux-yocto-rt
* just like linux-yocto-dev is doing * fixes following errors in world builds: ERROR: Nothing PROVIDES 'linux-yocto-rt' (but /home/jenkins/oe/world/shr-core/openembedded-core/meta/recipes-rt/images/core-image-rt-sdk.bb DEPENDS on or otherwise requires it) ERROR: linux-yocto-rt was skipped: PREFERRED_PROVIDER_virtual/kernel set to linux-yocto, not linux-yocto-rt ERROR: linux-yocto-rt was skipped: PREFERRED_PROVIDER_virtual/kernel set to linux-yocto, not linux-yocto-rt ERROR: Required build target 'core-image-rt-sdk' has no buildable providers. Missing or unbuildable dependency chain was: ['core-image-rt-sdk', 'linux-yocto-rt'] ERROR: Nothing PROVIDES 'linux-yocto-rt' (but /home/jenkins/oe/world/shr-core/openembedded-core/meta/recipes-rt/images/core-image-rt.bb DEPENDS on or otherwise requires it) ERROR: linux-yocto-rt was skipped: PREFERRED_PROVIDER_virtual/kernel set to linux-yocto, not linux-yocto-rt ERROR: linux-yocto-rt was skipped: PREFERRED_PROVIDER_virtual/kernel set to linux-yocto, not linux-yocto-rt ERROR: Required build target 'core-image-rt' has no buildable providers. Missing or unbuildable dependency chain was: ['core-image-rt', 'linux-yocto-rt'] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
index feef29f0f9..005c08893e 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
@@ -2,6 +2,15 @@ KBRANCH ?= "standard/preempt-rt"
require recipes-kernel/linux/linux-yocto.inc
+# Skip processing of this recipe if it is not explicitly specified as the
+# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
+# to build multiple virtual/kernel providers, e.g. as dependency of
+# core-image-rt-sdk, core-image-rt.
+python () {
+ if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-rt":
+ raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
+}
+
SRCREV_machine ?= "7ef3fe56827bd9c20021e3a52bc36ebd4c6b2ce3"
SRCREV_meta ?= "d6ee402d461048cf1afd10375fee5769c06d21d6"