aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-09-11 15:04:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-12 14:47:42 +0100
commitbf689c60caa905eb8866101b9e99dd4ae246a2ca (patch)
tree640e4fcb4a91e32c376b5955086ad074865541db /meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
parenta1d83d6aba91dad4935804801114d9d50ee0fab9 (diff)
downloadopenembedded-core-contrib-bf689c60caa905eb8866101b9e99dd4ae246a2ca.tar.gz
linux-yocto/3.4: add x32 configuration fragment
When x32 is the tuning for a x86 MACHINE, the kernel should also have CONFIG_X86_X32=y. This adds a x32 fragment that can be used to trigger the right ABI. The commit also contains a check for mx32 in TUNE_FEATURES, and if present, the new fragment will be appended to KERNEL_FEATURES and trigger the support in the kernel. cc: Saul Wold <sgw@linux.intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
index 4fd3845d5e..bbde730f77 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
@@ -10,7 +10,7 @@ KMETA = "meta"
SRCREV_machine ?= "a35693b1287c0e50cdca33a1b95af0ff48b43cd0"
SRCREV_machine_qemuppc ?= "85a1190530cb5749f5f831670976b163438dc301"
-SRCREV_meta ?= "d9d5fc63d8b38705036e946ea77d971d95de11ad"
+SRCREV_meta ?= "e0374ce012e7e6fc8e5bb8b957addb0478950898"
PR = "${INC_PR}.0"
PV = "${LINUX_VERSION}+git${SRCPV}"
@@ -27,3 +27,4 @@ KERNEL_FEATURES_append = " features/netfilter"
KERNEL_FEATURES_append = " features/taskstats"
KERNEL_FEATURES_append_qemux86 = " cfg/sound"
KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32", "" ,d)}"