summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-dev.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-02-04 14:13:37 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 09:35:04 +0000
commit378f99eeab070e2fcea84fb47f37cd7cb15caa90 (patch)
treec664908025980c85c0fa1d56ddae54a57516ba5e /meta/recipes-kernel/linux/linux-yocto-dev.bb
parentf0f5507f30b5d8d919e93cb6af6b724981e9cfef (diff)
downloadopenembedded-core-contrib-378f99eeab070e2fcea84fb47f37cd7cb15caa90.tar.gz
linux-yocto/dev: linux-yocto development tree tracking recipe
The linux-yocto-dev recipe uses the upstream tracking linux-yocto-dev repository. Since this tree is frequently updated, and periodically rebuilt, AUTOREV is used to track its contents. This recipe is just like other linux-yocto variants, with the only difference being that to avoid network access during initial parsing, static SRCREVs are provided and overridden if the preferred kernel provider is linux-yocto-dev. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-dev.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
new file mode 100644
index 0000000000..fdea085b53
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -0,0 +1,48 @@
+# This recipe tracks the linux-yocto-dev repository as its upstream source.
+# Since this tree is frequently updated, and periodically rebuilt, AUTOREV is
+# used to track its contents.
+#
+# This recipe is just like other linux-yocto variants, with the only difference
+# being that to avoid network access during initial parsing, static SRCREVs are
+# provided and overridden if the preferred kernel provider is linux-yocto-dev.
+#
+# To enable this recipe, set PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev"
+
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+KBRANCH = "standard/base"
+KBRANCH_DEFAULT = "${KBRANCH}"
+KMETA = "meta"
+
+SRC_URI = "git://git.pokylinux.org/linux-yocto-dev.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA};name=machine,meta"
+
+# Set default SRCREVs. Both the machine and meta SRCREVs are statically set
+# to the korg v3.7 tag, and hence prevent network access during parsing. If
+# linux-yocto-dev is the preferred provider, they will be overridden to
+# AUTOREV in following anonymous python routine and resolved when the
+# variables are finalized.
+SRCREV_machine="29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
+SRCREV_meta="29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
+
+python () {
+ if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
+ raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
+ else:
+ d.setVar("SRCREV_machine", "${AUTOREV}")
+ d.setVar("SRCREV_meta", "${AUTOREV}")
+}
+
+LINUX_VERSION ?= "3.8+"
+LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"
+PR = "r0"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
+
+# Functionality flags
+KERNEL_FEATURES_append = " features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
+KERNEL_FEATURES_append_qemux86=" cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"