summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod
diff options
context:
space:
mode:
authorJoshua Lock <joshua.lock@collabora.co.uk>2015-09-14 16:41:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-16 21:38:19 +0100
commitdc184ace9d72a2d4f8eeec831942663cd3b1fd47 (patch)
treec3b29b6f7ecad17a33de99207276a9f91b736589 /meta/recipes-kernel/kmod
parent518fce265e6f2b82f986fbda803e27b77f499c5a (diff)
downloadopenembedded-core-contrib-dc184ace9d72a2d4f8eeec831942663cd3b1fd47.tar.gz
kmod: fix link creation when base_bindir != /bin
If base_bindir is not a direct child of / the link creation in do_install_append creates incorrect relative links. Instead pass a full path to the link source too the lnr script to create a relative link. Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/kmod')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index ba4d85eda4..e0bb95c8f6 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -21,9 +21,9 @@ do_install_append () {
install -dm755 ${D}${base_bindir}
install -dm755 ${D}${base_sbindir}
# add symlinks to kmod
- ln -s ..${base_bindir}/kmod ${D}${base_bindir}/lsmod
+ lnr ${D}${base_bindir}/kmod ${D}${base_bindir}/lsmod
for tool in insmod rmmod depmod modinfo modprobe; do
- ln -s ..${base_bindir}/kmod ${D}${base_sbindir}/${tool}
+ lnr ${D}${base_bindir}/kmod ${D}${base_sbindir}/${tool}
done
# configuration directories
install -dm755 ${D}${base_libdir}/depmod.d