aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod
diff options
context:
space:
mode:
authorGeorge McCollister <george.mccollister@gmail.com>2016-01-14 14:56:36 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-30 11:37:02 +0000
commitd88ed5d3a0f497b3757c62bfb9c4a2a634c0bb5b (patch)
treed1402e3e9e2e8dcb0ac6ee29e210486b9c222842 /meta/recipes-kernel/kmod
parent0f3780cd1bb51347c21382ff3989cde71e7a5d01 (diff)
downloadopenembedded-core-contrib-d88ed5d3a0f497b3757c62bfb9c4a2a634c0bb5b.tar.gz
kmod: use bash-completion.bbclass
Use bash-completion.bbclass to package bash completions. (From OE-Core rev: 4f0716690ff4c7169b07e352df2301e77a3abc03) Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/kmod')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index e0bb95c8f6..69185b2453 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -39,7 +39,7 @@ do_compile_prepend() {
sed -i 's/ac_pwd=/#ac_pwd=/' config.status ; sed -i "/#ac_pwd=/a\ac_pwd='.'" config.status
}
-inherit update-alternatives
+inherit update-alternatives bash-completion
ALTERNATIVE_PRIORITY = "60"
@@ -56,8 +56,7 @@ ALTERNATIVE_TARGET[lsmod] = "${base_bindir}/lsmod.${BPN}"
ALTERNATIVE_LINK_NAME[depmod] = "${base_sbindir}/depmod"
-PACKAGES =+ "libkmod ${PN}-bash-completion"
+PACKAGES =+ "libkmod"
FILES_libkmod = "${base_libdir}/libkmod*${SOLIBS} ${libdir}/libkmod*${SOLIBS}"
FILES_${PN} += "${base_libdir}/depmod.d ${base_libdir}/modprobe.d"
-FILES_${PN}-bash-completion = "${datadir}/bash-completion"