aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-10-09 15:35:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-18 15:46:14 +0100
commit68322eadd1d9456e606b375c2f4181725784c292 (patch)
tree07e95a5d2f488d3641e29463868b994f58eefbe1 /meta/recipes-kernel/kmod
parent41a8c1f5fc0b4601af8b5b8b08f641668a39550d (diff)
downloadopenembedded-core-contrib-68322eadd1d9456e606b375c2f4181725784c292.tar.gz
kmod: Add patch to fix seperate build dir of ptest
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/kmod')
-rw-r--r--meta/recipes-kernel/kmod/kmod.inc1
-rw-r--r--meta/recipes-kernel/kmod/kmod/fix-seperatebuilddir.patch34
2 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kmod/kmod.inc b/meta/recipes-kernel/kmod/kmod.inc
index 633258b05e..880a53aa07 100644
--- a/meta/recipes-kernel/kmod/kmod.inc
+++ b/meta/recipes-kernel/kmod/kmod.inc
@@ -20,6 +20,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git \
file://run-ptest \
file://ptest.patch \
file://remove_parallel_tests.patch \
+ file://fix-seperatebuilddir.patch \
"
SRCREV = "3b38c7fcb58be4ddc34f90454c5f5dc3693d2d85"
diff --git a/meta/recipes-kernel/kmod/kmod/fix-seperatebuilddir.patch b/meta/recipes-kernel/kmod/kmod/fix-seperatebuilddir.patch
new file mode 100644
index 0000000000..b090eb56a5
--- /dev/null
+++ b/meta/recipes-kernel/kmod/kmod/fix-seperatebuilddir.patch
@@ -0,0 +1,34 @@
+
+If we are not building in the existing source tree, the testsuite
+directory will not exist so the cp of the stamp-rootfs would fail.
+
+Also added buildtest-TESTS so they could be build in the cross env,
+without running the tests.
+
+Upstream-Status: Accepted
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: git/Makefile.am
+===================================================================
+--- git.orig/Makefile.am
++++ git/Makefile.am
+@@ -131,7 +131,7 @@ endif
+
+ ROOTFS = testsuite/rootfs
+ ROOTFS_PRISTINE = $(top_srcdir)/testsuite/rootfs-pristine
+-CREATE_ROOTFS = $(AM_V_GEN) ( $(RM) -rf $(ROOTFS) && \
++CREATE_ROOTFS = $(AM_V_GEN) ( $(RM) -rf $(ROOTFS) && mkdir -p $(dir $(ROOTFS)) && \
+ cp -r $(ROOTFS_PRISTINE) $(ROOTFS) && \
+ touch testsuite/stamp-rootfs && \
+ find $(ROOTFS) -type d -exec chmod +w {} \; )
+@@ -217,6 +217,9 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-d
+
+ distclean-local: $(DISTCLEAN_LOCAL_HOOKS)
+
++buildtest-TESTS:
++ $(MAKE) $(AM_MAKEFLAGS) $(check_LTLIBRARIES) $(check_PROGRAMS)
++
+ install-ptest:
+ @$(MKDIR_P) $(DESTDIR)/testsuite
+ @for file in $(TESTSUITE); do \