aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod_git.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-04-13 09:55:04 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-15 14:18:53 +0100
commitf80d136bdd578468035a88125fa1b84973fd912b (patch)
tree603d126bdf6949700c03ef0dc33dc97df218ad28 /meta/recipes-kernel/kmod/kmod_git.bb
parente57437c0e02b148a878c8db91660674069fbd6e2 (diff)
downloadopenembedded-core-contrib-f80d136bdd578468035a88125fa1b84973fd912b.tar.gz
kmod: upgrade to 20
The following patches are rebased. -- Change-to-calling-bswap_-instead-of-htobe-and-be-toh.patch -- avoid_parallel_tests.patch The ptest part of kmod is removed because new version of kmod port all tests to use modules from module-playground instead of copying prebuilt modules to the repository. So, we cannot use ptest as before. Remove it so that kmod can build successfully. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index 08dd81569c..ba4d85eda4 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -33,27 +33,12 @@ do_install_append () {
# install depmod.d file for search/ dir
install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf"
-
- if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
- find testsuite -name *.ko -exec tar rf testmodule.tar {} \;
- find testsuite -name *.ko -exec rm -f {} \;
- fi
}
do_compile_prepend() {
sed -i 's/ac_pwd=/#ac_pwd=/' config.status ; sed -i "/#ac_pwd=/a\ac_pwd='.'" config.status
}
-do_compile_ptest () {
- oe_runmake buildtest-TESTS rootfs
-}
-
-do_install_ptest () {
- install testmodule.tar ${D}${PTEST_PATH}
-}
-
-INSANE_SKIP_${PN}-ptest = "arch"
-
inherit update-alternatives
ALTERNATIVE_PRIORITY = "60"