aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod-native_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-31 00:34:01 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-06 10:21:18 +0100
commit716606f5446534e48b45fcc017e8bbdfe7f15e26 (patch)
tree28e2acaf435ba751f424dedd22cb27faae18faaa /meta/recipes-kernel/kmod/kmod-native_git.bb
parentd3efcf15cee6734b4bf2277346ceba9a991fbd0f (diff)
downloadopenembedded-core-contrib-716606f5446534e48b45fcc017e8bbdfe7f15e26.tar.gz
kmod: Add recipes
kmod is replacement for module-init-tools Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod-native_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod-native_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kmod/kmod-native_git.bb b/meta/recipes-kernel/kmod/kmod-native_git.bb
new file mode 100644
index 0000000000..96de8b8ef4
--- /dev/null
+++ b/meta/recipes-kernel/kmod/kmod-native_git.bb
@@ -0,0 +1,14 @@
+# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require kmod.inc
+inherit native
+
+PR = "${INC_PR}.0"
+
+do_install_append (){
+ for tool in depmod insmod lsmod modinfo modprobe rmmod
+ do
+ ln -s kmod ${D}${bindir}/$tool
+ done
+}