aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-04-10 13:55:25 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-24 17:54:57 +0100
commite7aace7658fabe41839a3ec1b596bf28c6a4c02e (patch)
tree7d8d6ff94a2982e22de1987ebce2da2a8e44dc1c /meta/recipes-kernel/cryptodev
parent1a4feebf98780f586bf2e81cf9844e6805a50799 (diff)
downloadopenembedded-core-contrib-e7aace7658fabe41839a3ec1b596bf28c6a4c02e.tar.gz
cryptodev-linux: move to recipes-kernel to be shared with module and tests
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/cryptodev')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-linux_1.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-linux_1.6.bb b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.6.bb
new file mode 100644
index 0000000000..320716d6aa
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.6.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A /dev/crypto device driver"
+HOMEPAGE = "http://cryptodev-linux.org/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "http://download.gna.org/cryptodev-linux/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "eade38998313c25fd7934719cdf8a2ea"
+SRC_URI[sha256sum] = "75f1425c8ea1f8cae523905a5a046a35092327a6152800b0b86efc4e56fb3e2f"
+
+do_compile() {
+ :
+}
+
+# Just install cryptodev.h which is the only header file needed to be exported
+do_install() {
+ install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
+}
+
+ALLOW_EMPTY_${PN} = "1"
+BBCLASSEXTEND = "native nativesdk"