aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-16 16:02:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-27 11:26:56 +0000
commit762b3111f3124ee75404835da751fb95b8466fd4 (patch)
treeebf36c472f5ff59409b9d59d5707801946594c03 /meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb
parent2b19c74332c3899c84708946d749f88c4416cf73 (diff)
downloadopenembedded-core-contrib-762b3111f3124ee75404835da751fb95b8466fd4.tar.gz
cryptodev: update to 1.8
Drop 0001-ioctl.c-Fix-build-on-3.19.patch and 0002-Fix-tests-Makefile-usage-of-LDLIBS-vs.-LDFLAGS.patch, the code has been fixed upstream. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb
new file mode 100644
index 0000000000..c4005242a7
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb
@@ -0,0 +1,21 @@
+require cryptodev.inc
+
+SUMMARY = "A test suite for /dev/crypto device driver"
+
+DEPENDS += "openssl"
+
+SRC_URI += " \
+file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
+"
+
+EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"'
+
+do_compile() {
+ oe_runmake testprogs
+}
+
+do_install() {
+ oe_runmake install_tests
+}
+
+FILES_${PN} = "${bindir}/tests_cryptodev/*"