summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-09-13 14:52:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-14 00:14:45 +0100
commitcfda3e10d5eb1563d10318c1d8ff6287b539ee04 (patch)
tree1f7f7de024bbe35d2ec49800f3e5dee4b94e868c /meta/recipes-graphics
parentc696bdc424f1eadaa24dd8c0a8419e38f097f38a (diff)
downloadopenembedded-core-contrib-cfda3e10d5eb1563d10318c1d8ff6287b539ee04.tar.gz
weston-init: Select drm/fbdev backends for qemu machines
qemux86/x86_64/aarch64 supports drm backend well, therefore enable it on these qemu machines, other qemu machines should be defaulting to fbdev, if its not qemu then leave it empty Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb9
-rw-r--r--meta/recipes-graphics/wayland/weston-init/qemux86-64/weston.ini0
-rw-r--r--meta/recipes-graphics/wayland/weston-init/qemux86/weston.ini0
3 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 113f0ff599..07cec75fb3 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -15,6 +15,12 @@ SRC_URI = "file://init \
S = "${WORKDIR}"
+DEFAULTBACKEND ??= ""
+DEFAULTBACKEND_qemuall ?= "fbdev"
+DEFAULTBACKEND_qemuarm64 = "drm"
+DEFAULTBACKEND_qemux86 = "drm"
+DEFAULTBACKEND_qemux86-64 = "drm"
+
do_install() {
install -Dm755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
install -D -p -m0644 ${WORKDIR}/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
@@ -36,6 +42,9 @@ do_install() {
install -Dm755 ${WORKDIR}/weston-start ${D}${bindir}/weston-start
sed -i 's,@DATADIR@,${datadir},g' ${D}${bindir}/weston-start
sed -i 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${bindir}/weston-start
+ if [ -n "${DEFAULTBACKEND}" ]; then
+ sed -i -e "/^\[core\]/a backend=${DEFAULTBACKEND}-backend.so" ${D}${sysconfdir}/xdg/weston/weston.ini
+ fi
}
inherit update-rc.d features_check systemd
diff --git a/meta/recipes-graphics/wayland/weston-init/qemux86-64/weston.ini b/meta/recipes-graphics/wayland/weston-init/qemux86-64/weston.ini
deleted file mode 100644
index e69de29bb2..0000000000
--- a/meta/recipes-graphics/wayland/weston-init/qemux86-64/weston.ini
+++ /dev/null
diff --git a/meta/recipes-graphics/wayland/weston-init/qemux86/weston.ini b/meta/recipes-graphics/wayland/weston-init/qemux86/weston.ini
deleted file mode 100644
index e69de29bb2..0000000000
--- a/meta/recipes-graphics/wayland/weston-init/qemux86/weston.ini
+++ /dev/null