aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-07-03 17:53:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-07 23:57:12 +0100
commita9c174fd4bfabbae00d947738b06e72d7809eab3 (patch)
tree04fd5525b0d8bb5b45b06bfb82405a58b85ed424 /meta/recipes-graphics
parentf71909f5eacc23d8533f1860ab890892d4f93f29 (diff)
downloadopenembedded-core-contrib-a9c174fd4bfabbae00d947738b06e72d7809eab3.tar.gz
mesa-demos: rename clear
ncurses have already provided clear,so rename it to clear.mesa-demos. [ RB - check that clear exists before moving ] Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
index e565442fc6..d58388aabb 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
@@ -48,6 +48,10 @@ PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
do_install_append() {
- # it can be completely empty when all PACKAGECONFIG options are disabled
- rmdir --ignore-fail-on-non-empty ${D}${bindir}
+ # it can be completely empty when all PACKAGECONFIG options are disabled
+ rmdir --ignore-fail-on-non-empty ${D}${bindir}
+
+ if [ -f ${D}${bindir}/clear ]; then
+ mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
+ fi
}