aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-04 16:29:53 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-06 23:08:56 +0000
commit20031e167f772ce2eb3ba4b93adb82c1f4805d42 (patch)
tree1c0b851e91681e4ccd137d29bc5d8130f245492b /meta/recipes-graphics
parent71e374aa5b6c466cc6ddfffeaa7cee9a6b3d2f0e (diff)
downloadopenembedded-core-contrib-20031e167f772ce2eb3ba4b93adb82c1f4805d42.tar.gz
pango: unset LDFLAGS when building gen_all_unicode
When building the native gen_all_unicode binary we need to also unset LDFLAGS as otherwise the *target* LDFLAGS will be used. At best the options are harmless but if there are options that the host compiler doesn't support then the compile will fail. For example, if the host gcc is version 4.8 but LDFLAGS contains -fstack-protector-strong which in 4.9 onwards. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/pango/pango_1.38.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.38.1.bb b/meta/recipes-graphics/pango/pango_1.38.1.bb
index d408ef00e1..3e57dc2275 100644
--- a/meta/recipes-graphics/pango/pango_1.38.1.bb
+++ b/meta/recipes-graphics/pango/pango_1.38.1.bb
@@ -35,7 +35,7 @@ LIBV = "1.8.0"
# This binary needs to be compiled for the host architecture. This isn't pretty!
do_compile_prepend_class-target () {
if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
- make CC="${BUILD_CC}" CFLAGS="" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
+ make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
fi
}