aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-07-20 23:36:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-23 18:06:10 +0100
commitbcd93a4ad1188bb15db00727d5d03548d687a7a3 (patch)
tree8b4939681a60ce0de72daac19eff1d9457c595f4 /meta/recipes-graphics
parenta32dac24808bf8621fdbbecb654eff784acee47e (diff)
downloadopenembedded-core-contrib-bcd93a4ad1188bb15db00727d5d03548d687a7a3.tar.gz
libinput: fix udevdir
* Use "pkg-config --variable=udevdir udev" to fix udevdir, otherwise it would use ${libdir}/udev which is incorrect for systemd's udev. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.4.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.4.1.bb b/meta/recipes-graphics/wayland/libinput_1.4.1.bb
index c3905f3d9a..3580392260 100644
--- a/meta/recipes-graphics/wayland/libinput_1.4.1.bb
+++ b/meta/recipes-graphics/wayland/libinput_1.4.1.bb
@@ -20,4 +20,6 @@ PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
PACKAGECONFIG[libwacom] = "--enable-libwacom,--disable-libwacom,libwacom"
PACKAGECONFIG[gui] = "--enable-event-gui,--disable-event-gui,cairo gtk+3"
-FILES_${PN} += "${libdir}/udev/"
+UDEVDIR = "`pkg-config --variable=udevdir udev`"
+
+EXTRA_OECONF += "--with-udev-dir=${UDEVDIR}"