aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-04 13:09:11 +0000
committerAndreas Oberritter <obi@opendreambox.org>2015-02-23 16:51:54 +0100
commitb2b95782eb9c696975aa27bff591cbfbb4a17503 (patch)
treed0802a8b27de96130e9ad3544254841a6967424e /meta/recipes-graphics
parentb114d30f17778d34e1edd71486ab063742640ee9 (diff)
downloadopenembedded-core-contrib-b2b95782eb9c696975aa27bff591cbfbb4a17503.tar.gz
classes/recipes: More optimal DISTRO_FEATURES references
Using the contains function results in more optimal sstate checksums resulting in better cache reuse as we as more consistent code. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 9c93526756e7cbbff027c88eb972f877bcb1f057)
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/wayland/weston_1.1.0.bb16
1 files changed, 7 insertions, 9 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.1.0.bb b/meta/recipes-graphics/wayland/weston_1.1.0.bb
index 8280bf266f..5bec96cd9b 100644
--- a/meta/recipes-graphics/wayland/weston_1.1.0.bb
+++ b/meta/recipes-graphics/wayland/weston_1.1.0.bb
@@ -59,16 +59,14 @@ do_install_append() {
# Weston doesn't need the .la files to load modules, so wipe them
rm -f ${D}/${libdir}/weston/*.la
- for feature in ${DISTRO_FEATURES}; do
- # If X11, ship a desktop file to launch it
- if [ "$feature" = "x11" ]; then
- install -d ${D}${datadir}/applications
- install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
+ # If X11, ship a desktop file to launch it
+ if [ "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "x11" ]; then
+ install -d ${D}${datadir}/applications
+ install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
- install -d ${D}${datadir}/icons/hicolor/48x48/apps
- install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
- fi
- done
+ install -d ${D}${datadir}/icons/hicolor/48x48/apps
+ install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
+ fi
}
PACKAGES += "${PN}-examples"