aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-09-13 12:57:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-22 13:09:02 +0100
commitcff055403eab8112ef76cd6331682447bcddf760 (patch)
tree68e005d895fadff8270dd2c7e7df50f6993dbc4d /meta/recipes-graphics
parent6a90852e7e8fd6d17308d78966e700f17f567898 (diff)
downloadopenembedded-core-contrib-cff055403eab8112ef76cd6331682447bcddf760.tar.gz
libsdl2: allow to build native and nativesdk
* enable x11 in native builds Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
index c0cf70d7fd..c37f669321 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
@@ -37,6 +37,8 @@ EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
# and BSP layers to pick either (desktop) opengl, gles2, or no GL
PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
+PACKAGECONFIG_class-native = "x11"
+PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
PACKAGECONFIG ??= " \
${PACKAGECONFIG_GL} \
${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \
@@ -63,3 +65,5 @@ do_configure_prepend() {
}
FILES_${PN}-dev += "${libdir}/cmake"
+
+BBCLASSEXTEND = "native nativesdk"