aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-09-22 02:36:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-15 10:01:43 +0100
commita489cb14b99e91b3afa72f767364913446aa2483 (patch)
tree651a1df6a24491a978967aa57224949cc5aa6983 /meta/recipes-graphics
parent49d189e2415137d2091d72c3c7fd0dd45f53d908 (diff)
downloadopenembedded-core-contrib-a489cb14b99e91b3afa72f767364913446aa2483.tar.gz
xcb-proto: create .pyc files for python2
Its Makefile's do_install creates .pyc files for python3, now also create them for python2 so that they will be recorded by manifest, and can be cleaned correctly. (From OE-Core rev: 3007f8b365270c35fdb1829d83affd98d8d5475a) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
index 8bdca32b71..7d4a6b4364 100644
--- a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
@@ -28,3 +28,10 @@ RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
BBCLASSEXTEND = "native nativesdk"
+
+do_install_append() {
+ # Makefile's do_install creates .pyc files for python3, now also create
+ # them for python2 so that they will be recorded by manifest, and can be
+ # cleaned correctly.
+ python -m py_compile ${D}${libdir}/xcb-proto/xcbgen/*.py
+}