aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-10-26 11:37:38 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-01 10:05:45 +0000
commita1668c8721709f3d1bc0078737514111e1985bdd (patch)
tree8c9324a2f17f5c92dd74e89620752f2cf2b1fad3 /meta/recipes-graphics
parent95502c3a58d6441f1ac9417186dee1c4e13f3abc (diff)
downloadopenembedded-core-contrib-a1668c8721709f3d1bc0078737514111e1985bdd.tar.gz
conf: Use xf86-input-libinput by default
Don't install legacy X input drivers for any machines by default, RRECOMMEND xf86-input-libinput instead. This is the setup suggested by upstream: install only libinput by default, but let niche legacy drivers sort higher in configuration so they get chosen if installed. So the order is: evdev < libinput < (synaptics|vmmouse|...) This also removes vmmouse X driver from the qemu config. If a VMware virtual mouse device really needs to be supported, we should enable CONFIG_MOUSE_PS2_VMMOUSE in kernel instead: that is directly supported by the libinput X driver. Fixes [YOCTO #10195]. (From OE-Core rev: 2d005faff6341a81a2afae28860101ba9db51ae8) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb2
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
index 6b50028562..97dcac5f79 100644
--- a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
@@ -11,7 +11,7 @@ inherit packagegroup distro_features_check
# rdepends on XSERVER
REQUIRED_DISTRO_FEATURES = "x11"
-XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+XSERVER ?= "xserver-xorg xf86-video-fbdev"
XSERVERCODECS ?= ""
RDEPENDS_${PN} = "\
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc b/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
index 29503b1a53..269fa63048 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
@@ -71,7 +71,7 @@ PACKAGES =+ "${PN}-sdl \
SUMMARY_xf86-video-modesetting = "X.Org X server -- modesetting display driver"
INSANE_SKIP_${MLPREFIX}xf86-video-modesetting = "xorg-driver-abi"
-XSERVER_RRECOMMENDS = "xkeyboard-config rgb xserver-xf86-config xkbcomp"
+XSERVER_RRECOMMENDS = "xkeyboard-config rgb xserver-xf86-config xkbcomp xf86-input-libinput"
RRECOMMENDS_${PN} += "${XSERVER_RRECOMMENDS}"
RRECOMMENDS_${PN}-xwayland += "${XSERVER_RRECOMMENDS}"
RDEPENDS_${PN}-xvfb += "xkeyboard-config"