aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-05-16 16:22:49 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-17 14:43:06 +0100
commitfc1f9c487de5a54a767932bcee7db039e3bcef30 (patch)
treee7c5271ca8997721a2ed87afd5a738d31b549c65 /meta/recipes-graphics
parent7d278ef0a28f47c75570f0f9c5d627d07f925045 (diff)
downloadopenembedded-core-contrib-fc1f9c487de5a54a767932bcee7db039e3bcef30.tar.gz
wayland-protocols: Add recipe
wayland-protocols is a collection of Wayland protocols split out from weston. It is a build dependency for Weston 1.10. * Added a patch to enable allarch build. * Use HTTPS for tarball uri. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/wayland/wayland-protocols/dont-use-AC_CANONICAL.patch29
-rw-r--r--meta/recipes-graphics/wayland/wayland-protocols_1.3.bb20
2 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland-protocols/dont-use-AC_CANONICAL.patch b/meta/recipes-graphics/wayland/wayland-protocols/dont-use-AC_CANONICAL.patch
new file mode 100644
index 0000000000..6cc0f3bfc1
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland-protocols/dont-use-AC_CANONICAL.patch
@@ -0,0 +1,29 @@
+Check autoconfs $cross_compiling instead as AC_CANONICAL_HOST call
+will fail if the host cpu is not recognised (which can happen when
+e.g. Yocto builds for "allarch").
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Upstream-Status: Backport [cc276dfa41]
+
+diff --git a/configure.ac b/configure.ac
+index 5b48b1a..3d45a4b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,13 +15,10 @@ AC_CONFIG_MACRO_DIR([m4])
+
+ AC_SUBST([WAYLAND_PROTOCOLS_VERSION], [wayland_protocols_version])
+
+-AC_CANONICAL_HOST
+-AC_CANONICAL_BUILD
+-
+ AC_ARG_VAR([wayland_scanner], [The wayland-scanner executable])
+ AC_PATH_PROG([wayland_scanner], [wayland-scanner])
+ if test x$wayland_scanner = x; then
+- if test x$host = x$build; then
++ if test "x$cross_compiling" != "xyes"; then
+ PKG_CHECK_MODULES(WAYLAND_SCANNER, [wayland-scanner])
+ wayland_scanner=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`
+ else
+--
+cgit v0.10.2
+
diff --git a/meta/recipes-graphics/wayland/wayland-protocols_1.3.bb b/meta/recipes-graphics/wayland/wayland-protocols_1.3.bb
new file mode 100644
index 0000000000..86e89b5946
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland-protocols_1.3.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Collection of additional Wayland protocols"
+DESCRIPTION = "Wayland protocols that add functionality not \
+available in the Wayland core protocol. Such protocols either add \
+completely new functionality, or extend the functionality of some other \
+protocol either in Wayland core, or some other protocol in \
+wayland-protocols."
+HOMEPAGE = "http://wayland.freedesktop.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c7b12b6702da38ca028ace54aae3d484 \
+ file://stable/presentation-time/presentation-time.xml;endline=26;md5=4646cd7d9edc9fa55db941f2d3a7dc53"
+
+SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
+ file://dont-use-AC_CANONICAL.patch"
+SRC_URI[md5sum] = "88b5e3dce52908c7e74fad3e2cf8abb0"
+SRC_URI[sha256sum] = "6bcd0633fdf9225ef1c7d2831f542e947f7d79811c79fc37f57b2e5375ded82f"
+
+inherit allarch autotools pkgconfig
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${datadir}/pkgconfig/wayland-protocols.pc"