aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-02-23 12:05:02 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:35 +0000
commit6e779962f3846cbe5a5cb205f66b9bd9404f6d57 (patch)
tree6ca33b1b8ee0577bcc7ea6964c3276536304383e /meta/recipes-graphics
parent74b5088f1cc1708db43c33ac2dc7f01f4a4db9c1 (diff)
downloadopenembedded-core-contrib-6e779962f3846cbe5a5cb205f66b9bd9404f6d57.tar.gz
libdrm: fix build with uclibc
Fix 'O_CLOEXEC' undeclared error with uclibc Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch24
-rw-r--r--meta/recipes-graphics/drm/libdrm_2.4.66.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch b/meta/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch
new file mode 100644
index 0000000000..286e548bc9
--- /dev/null
+++ b/meta/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch
@@ -0,0 +1,24 @@
+drmdevice.c: define _GNU_SOURCE
+
+Include config.h to fix this build error with uclibc:
+
+libdrm-2.4.66/tests/drmdevice.c: In function 'main':
+libdrm-2.4.66/tests/drmdevice.c:96:60: error:
+'O_CLOEXEC' undeclared (first use in this function)
+fd = open(devices[i]->nodes[j],O_RDONLY | O_CLOEXEC, 0);
+
+Upstream-Status: Pending
+
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
+---
+diff -Naur libdrm-2.4.66-orig/tests/drmdevice.c libdrm-2.4.66/tests/drmdevice.c
+--- libdrm-2.4.66-orig/tests/drmdevice.c 2016-02-23 11:34:02.054904502 +0200
++++ libdrm-2.4.66/tests/drmdevice.c 2016-02-23 11:35:34.371750383 +0200
+@@ -21,6 +21,7 @@
+ *
+ */
+
++#include <config.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/stat.h>
diff --git a/meta/recipes-graphics/drm/libdrm_2.4.66.bb b/meta/recipes-graphics/drm/libdrm_2.4.66.bb
index 3280920de1..79cd94af8c 100644
--- a/meta/recipes-graphics/drm/libdrm_2.4.66.bb
+++ b/meta/recipes-graphics/drm/libdrm_2.4.66.bb
@@ -14,6 +14,7 @@ SRC_URI = "http://dri.freedesktop.org/libdrm/${BP}.tar.bz2 \
file://installtests.patch \
file://0001-tests-kms-steal-crtc-Include-sys-select.h.patch \
file://detect.patch \
+ file://fix_O_CLOEXEC_undeclared.patch \
"
SRC_URI[md5sum] = "c6809c48538d6e5999588832045ff014"