aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorValentin Popa <valentin.popa@intel.com>2014-02-13 15:45:19 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-17 15:27:56 +0000
commit46100431a726010645824a84850fd7bef8cc923b (patch)
treead438392a92e3a83b95ad0fc787dbc00d15b3f58 /meta/recipes-graphics
parent270ed9322dbd40b61e31ee9ab27cf7af5d433c1c (diff)
downloadopenembedded-core-contrib-46100431a726010645824a84850fd7bef8cc923b.tar.gz
wayland: upgrade to 1.4.0
(*) tested on qemux86 and genericx86 with core-image-weston and core-image-sato Signed-off-by: Valentin Popa <valentin.popa@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/wayland/wayland/just-scanner.patch21
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.4.0.bb (renamed from meta/recipes-graphics/wayland/wayland_1.3.0.bb)6
2 files changed, 20 insertions, 7 deletions
diff --git a/meta/recipes-graphics/wayland/wayland/just-scanner.patch b/meta/recipes-graphics/wayland/wayland/just-scanner.patch
index 234a9c5f79..ae9935e089 100644
--- a/meta/recipes-graphics/wayland/wayland/just-scanner.patch
+++ b/meta/recipes-graphics/wayland/wayland/just-scanner.patch
@@ -1,3 +1,8 @@
+From f674544d4f6f5f763e449207da77a561b22eff97 Mon Sep 17 00:00:00 2001
+From: Valentin Popa <valentin.popa@intel.com>
+Date: Fri, 7 Feb 2014 16:36:47 +0200
+Subject: [PATCH] just scanner
+
We only build wayland-native for the scanner, so disable the bits we don't
actually need. This gives us a small speed up but importantly should allow
wayland-native to compile on older hosts such as CentOS 5 which currently fails:
@@ -10,22 +15,27 @@ wayland-native to compile on older hosts such as CentOS 5 which currently fails:
Upstream-Status: Inappropriate
Signed-off-by: Ross Burton <ross.burton@intel.com>
+Signed-off-by: Valentin Popa <valentin.popa@intel.com>
+---
+ Makefile.am | 2 +-
+ src/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile.am b/Makefile.am
-index 306d7b3..571fe89 100644
+index 99607b0..ecce1f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ if BUILD_DOCS
doc_subdir = doc
endif
--SUBDIRS = src protocol $(doc_subdir) tests cursor
-+SUBDIRS = src protocol $(doc_subdir)
+-SUBDIRS = protocol src $(doc_subdir) tests cursor
++SUBDIRS = protocol src $(doc_subdir)
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
diff --git a/src/Makefile.am b/src/Makefile.am
-index e1d04ea..702342e 100644
+index 15f44a5..b938d17 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
@@ -34,3 +44,6 @@ index e1d04ea..702342e 100644
noinst_LTLIBRARIES = libwayland-util.la
include_HEADERS = \
+--
+1.8.3.2
+
diff --git a/meta/recipes-graphics/wayland/wayland_1.3.0.bb b/meta/recipes-graphics/wayland/wayland_1.4.0.bb
index aa04f8d1c5..0f08cacfea 100644
--- a/meta/recipes-graphics/wayland/wayland_1.3.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.4.0.bb
@@ -11,10 +11,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
-SRC_URI[md5sum] = "d16d27081e0871de82d08840c2f133fc"
-SRC_URI[sha256sum] = "2e817685f68a26acd19964d69ddbc4549ba5412114ad95e1a9f5934cce470d6e"
+SRC_URI[md5sum] = "332cf9191837be12638a29265ed7cf46"
+SRC_URI[sha256sum] = "18f33b9f15b4c8b662fb1968e7636e7926b419dfc48de8a164b3a3d7095c5a58"
SRC_URI_append_class-native = " file://just-scanner.patch"
+EXTRA_OECONF_class-native = "--disable-documentation --enable-scanner"
inherit autotools pkgconfig
@@ -24,7 +25,6 @@ BBCLASSEXTEND = "native"
DEPENDS_class-native = "expat-native libffi-native"
DEPENDS = "expat libffi wayland-native"
-EXTRA_OECONF_class-native = "--disable-documentation"
EXTRA_OECONF = "--disable-documentation --disable-scanner"
# Wayland installs a M4 macro for other projects to use, which uses the target