aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorDrew Moseley <drew_moseley@mentor.com>2014-05-12 16:10:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-29 13:42:10 +0100
commit1a965b2ecca07d231a8058e453cbeafacc5b6c69 (patch)
treee0a4ebcd654c29e6afd8045ad117d8c137f35780 /meta/recipes-graphics
parent359a3317684cdd61b35bf569b0b65148e89abe12 (diff)
downloadopenembedded-core-contrib-1a965b2ecca07d231a8058e453cbeafacc5b6c69.tar.gz
mesa-demos: Specify the lib dir properly.
Use STAGING_EXECPREFIXDIR to specify the location of glut header files and libs rather than STAGING_LIBDIR. Also revert the previous unneeded change to glut.patch. (From OE-Core rev: f38c1846184722180d9091a7a5c1e6e20eed7f2c) Signed-off-by: Drew Moseley <drew_moseley@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos/glut.patch2
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos/glut.patch b/meta/recipes-graphics/mesa/mesa-demos/glut.patch
index 2ca5a938ac..84b6d4f7f3 100644
--- a/meta/recipes-graphics/mesa/mesa-demos/glut.patch
+++ b/meta/recipes-graphics/mesa/mesa-demos/glut.patch
@@ -27,7 +27,7 @@ Index: mesa-demos-8.0.1/configure.ac
- [glutInit],
- [],
- [glut_enabled=no])
-+ GLUT_LIBS="-L$withval -lglut"],
++ GLUT_LIBS="-L$withval/lib -lglut"],
+ [GLUT_CFLAGS=""
+ GLUT_LIBS="-lglut"]
+ )
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
index 70ade94eec..08269368c2 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
@@ -33,7 +33,7 @@ PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
-PACKAGECONFIG[glut] = "--with-glut=${STAGING_LIBDIR},--without-glut,"
+PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,"
PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libvg"
PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"