summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xwayland/xwayland_22.1.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-05-05 07:05:30 +0200
committerSteve Sakoman <steve@sakoman.com>2022-05-16 13:59:44 -1000
commit8b8f53ebf6bc265d495154fea3050fe8d7fbd256 (patch)
treebacd838fa79d686d91e23da1a0c70a0fcd5e3b58 /meta/recipes-graphics/xwayland/xwayland_22.1.1.bb
parentcf336712afc3899ef45c7f2ef5f6b081223a1269 (diff)
downloadopenembedded-core-contrib-8b8f53ebf6bc265d495154fea3050fe8d7fbd256.tar.gz
xwayland: upgrade 22.1.0 -> 22.1.1
Changes in XWayland 22.1.1 include: - Not mapping the composite overlay window by default when running in rootless mode. This is being done since a client trying to get the COW, the X Server will map the window and block all pointer events. - A change to the XWayland present queue code due to some Vulkan games/apps running in windowed mode only running at 58 FPS when in fact at 60 FPS for matching a 60Hz refresh rate. Incorrect calculation handling led to the MSC ticking at ~58Hz. - Fixing use-after-free bugs. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit aa0028e19651665f6671d7c57646cfc97c7ba763) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-graphics/xwayland/xwayland_22.1.1.bb')
-rw-r--r--meta/recipes-graphics/xwayland/xwayland_22.1.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xwayland/xwayland_22.1.1.bb b/meta/recipes-graphics/xwayland/xwayland_22.1.1.bb
new file mode 100644
index 0000000000..b512b9932d
--- /dev/null
+++ b/meta/recipes-graphics/xwayland/xwayland_22.1.1.bb
@@ -0,0 +1,45 @@
+SUMMARY = "XWayland is an X Server that runs under Wayland."
+DESCRIPTION = "XWayland is an X Server running as a Wayland client, \
+and thus is capable of displaying native X11 client applications in a \
+Wayland compositor environment. The goal of XWayland is to facilitate \
+the transition from X Window System to Wayland environments, providing \
+a way to run unported applications in the meantime."
+HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
+
+SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz"
+SRC_URI[sha256sum] = "f5d0e0ba37e19bb87c62f61da5970bd204939f2120620964bed4cc8495baa657"
+
+UPSTREAM_CHECK_REGEX = "xwayland-(?P<pver>\d+(\.(?!90\d)\d+)+)\.tar"
+
+inherit meson features_check pkgconfig
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
+
+DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy libxcvt"
+
+OPENGL_PKGCONFIGS = "glx glamor dri3"
+PACKAGECONFIG ??= "${XORG_CRYPTO} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${OPENGL_PKGCONFIGS}', '', d)} \
+"
+PACKAGECONFIG[dri3] = "-Ddri3=true,-Ddri3=false"
+PACKAGECONFIG[glx] = "-Dglx=true,-Dglx=false,virtual/libgl virtual/libx11"
+PACKAGECONFIG[glamor] = "-Dglamor=true,-Dglamor=false,libepoxy virtual/libgbm,libegl"
+PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
+PACKAGECONFIG[xinerama] = "-Dxinerama=true,-Dxinerama=false"
+
+# Xorg requires a SHA1 implementation, pick one
+XORG_CRYPTO ??= "openssl"
+PACKAGECONFIG[openssl] = "-Dsha1=libcrypto,,openssl"
+PACKAGECONFIG[nettle] = "-Dsha1=libnettle,,nettle"
+PACKAGECONFIG[gcrypt] = "-Dsha1=libgcrypt,,libgcrypt"
+
+do_install:append() {
+ # remove files not needed and clashing with xserver-xorg
+ rm -rf ${D}/${libdir}/xorg/
+}
+
+FILES:${PN} += "${libdir}/xorg/protocol.txt"
+
+RDEPENDS:${PN} += "xkbcomp"