aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-02-20 22:43:53 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:35 +0000
commitc27c60fe012bf42ea3b22fc1b4496450dc68b50b (patch)
treef0fc78e6881f880e8f792cc2128387344acb1d65 /meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
parent1ae5ede208c82733293492a6eb836ff8b1197f4e (diff)
downloadopenembedded-core-contrib-c27c60fe012bf42ea3b22fc1b4496450dc68b50b.tar.gz
xcb-proto: don't compile for Python 2
Remove the do_install_append to create the Python 2 pyc files, as nothing in the build is using Python 2 anymore (libxcb is the only user, and that uses Python 3). Also use variables instead of a patch to control what Python binary and path the modules are installed to. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb')
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
index be6b1a0200..712ab6c59a 100644
--- a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
@@ -11,8 +11,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7 \
file://src/dri2.xml;beginline=2;endline=28;md5=f8763b13ff432e8597e0d610cf598e65"
-SRC_URI = "http://xcb.freedesktop.org/dist/xcb-proto-${PV}.tar.bz2 \
- file://no-python-native.patch \
+SRC_URI = "http://xcb.freedesktop.org/dist/${BP}.tar.bz2 \
file://0001-Make-whitespace-use-consistent.patch \
file://0002-print-is-a-function-and-needs-parentheses.patch \
"
@@ -21,6 +20,10 @@ SRC_URI[sha256sum] = "5922aba4c664ab7899a29d92ea91a87aa4c1fc7eb5ee550325c3216c48
inherit autotools pkgconfig
+# Force the use of Python 3 and a specific library path so we don't need to
+# depend on python3-native
+CACHED_CONFIGUREVARS += "PYTHON=python3 am_cv_python_pythondir=${libdir}/xcb-proto"
+
PACKAGES += "python-xcbgen"
FILES_${PN} = ""
@@ -31,10 +34,3 @@ RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
BBCLASSEXTEND = "native nativesdk"
-
-do_install_append() {
- # Makefile's do_install creates .pyc files for python3, now also create
- # them for python2 so that they will be recorded by manifest, and can be
- # cleaned correctly.
- (cd ${D}; python -m py_compile ./${libdir}/xcb-proto/xcbgen/*.py)
-}