aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-09-22 02:36:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-15 09:54:24 +0100
commit3007f8b365270c35fdb1829d83affd98d8d5475a (patch)
treeff188fd934c6fb343b8c0f97050e5dcba5a586ab /meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
parent3753d07c9ff33b9a97aca61ad312b0e283c4c68d (diff)
downloadopenembedded-core-contrib-3007f8b365270c35fdb1829d83affd98d8d5475a.tar.gz
xcb-proto: create .pyc files for python2
Its Makefile's do_install creates .pyc files for python3, now also create them for python2 so that they will be recorded by manifest, and can be cleaned correctly. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb')
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
index 8bdca32b71..7d4a6b4364 100644
--- a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
@@ -28,3 +28,10 @@ RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
BBCLASSEXTEND = "native nativesdk"
+
+do_install_append() {
+ # Makefile's do_install creates .pyc files for python3, now also create
+ # them for python2 so that they will be recorded by manifest, and can be
+ # cleaned correctly.
+ python -m py_compile ${D}${libdir}/xcb-proto/xcbgen/*.py
+}