summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-01 11:47:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-02 11:35:06 +0000
commit34ef5c2a8d77fcb4a51c875a443f7b97b409586e (patch)
tree94ac333f651cf9c9f72658bbb0748425f1dfb310 /meta/recipes-graphics/xorg-lib
parentd76b33c6a8489378a1f5500554367127199ae19d (diff)
downloadopenembedded-core-contrib-34ef5c2a8d77fcb4a51c875a443f7b97b409586e.tar.gz
libxcb: Fix install file owner/group
The makefile uses cp -P behind the scenes for installing the tutorial files and this preserves the build user identity. Fix this to the correct owner/group. Usually do_package fixes and hides this but it can be seen in do_install. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.14.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
index f27c5daa61..e9f6051b6e 100644
--- a/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
@@ -30,6 +30,10 @@ REQUIRED_DISTRO_FEATURES = "x11"
export PYTHON = "python3"
+do_install_append () {
+ chown root.root ${D}${datadir}/doc/${BPN}/tutorial -R
+}
+
python populate_packages_prepend () {
do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
}