aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-12-11 15:08:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-27 11:26:59 +0000
commitbc38ef47b05128623a916172c2cfd244510b201e (patch)
treec8e350eb97de3107ab5d555df116d9d1aa56a075 /meta/recipes-graphics/xorg-lib
parent3ec457e7cdc347a98ab561fd3d2a500a218cdeb0 (diff)
downloadopenembedded-core-contrib-bc38ef47b05128623a916172c2cfd244510b201e.tar.gz
xcb: don't build-depend on python-native
xcb-proto had a dependency on python-native as it builds and installs a Python module, but xcb-proto is very low in the build to force a dependency on python-native. As it turns out libxcb simply asks pkg-config for the full path to the module xcb-proto installed and uses it directly so there is no need to build python-native. Instead replace AM_PATH_PYTHON with two explicit variable definitions (need to set PYTHON for automake's install logic). Also remove the dependency on xcb-proto-native as libxcb uses the data files and tooling from the target sysroot, and patching it to use the native sysroot adds complication for no good reason. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.11.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.11.1.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.11.1.bb
index 6b944c9b0b..4372be1a0d 100644
--- a/meta/recipes-graphics/xorg-lib/libxcb_1.11.1.bb
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.11.1.bb
@@ -19,13 +19,13 @@ SRC_URI[sha256sum] = "b720fd6c7d200e5371affdb3f049cc8f88cff9aed942ff1b824d95eedb
BBCLASSEXTEND = "native nativesdk"
-DEPENDS = "xcb-proto xproto libxau xcb-proto-native libpthread-stubs libxdmcp"
+DEPENDS = "xcb-proto xproto libxau libpthread-stubs libxdmcp"
PACKAGES_DYNAMIC = "^libxcb-.*"
FILES_${PN} = "${libdir}/libxcb.so.*"
-inherit autotools pkgconfig pythonnative distro_features_check
+inherit autotools pkgconfig distro_features_check
# The libxau and others requires x11 in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES = "x11"