aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-12-09 16:58:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-10 11:28:15 +0000
commite7876641c684448c6760050f23fd17dd5e850b48 (patch)
tree36456919cc431d39cb3e0855de99a521d24c52b1 /meta/recipes-graphics/xorg-lib/libxcb
parent380d48da4b476f43554e38e464e7e25c930f88b6 (diff)
downloadopenembedded-core-contrib-e7876641c684448c6760050f23fd17dd5e850b48.tar.gz
libxcb: fix rebuild when MACHINE changes
This recipe was patching the sysroot path directly into configure.ac, which fails when the same source tree is re-used for another machine. Instead, patch in $PKG_CONFIG_SYSROOT_DIR which is already exported for use by pkg-config. Also remove some commented-out lines that have no purpose. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch23
1 files changed, 19 insertions, 4 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch b/meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch
index d858a63b72..46297c33c3 100644
--- a/meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch
+++ b/meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch
@@ -1,8 +1,14 @@
-Upstream-Status: Inappropriate [configuration]
+As pkg-config --variable doesn't respect the sysroot, add the pkg-config sysroot
+to the beginning of variables that are used later on the host.
---- libxcb-1.0.orig/configure.ac 2006-11-23 15:33:01.000000000 +0000
-+++ libxcb-1.0/configure.ac 2008-09-10 20:29:12.000000000 +0100
-@@ -50,7 +50,7 @@
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/configure.ac b/configure.ac
+index 94da4f7..d29cd6a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -64,7 +64,7 @@ AC_SUBST(NEEDED)
# Find the xcb-proto protocol descriptions
AC_MSG_CHECKING(XCBPROTO_XCBINCLUDEDIR)
@@ -11,3 +17,12 @@ Upstream-Status: Inappropriate [configuration]
AC_MSG_RESULT($XCBPROTO_XCBINCLUDEDIR)
AC_SUBST(XCBPROTO_XCBINCLUDEDIR)
+@@ -74,7 +74,7 @@ AC_SUBST(XCBPROTO_VERSION)
+
+ # Find the xcbgen Python package
+ AC_MSG_CHECKING(XCBPROTO_XCBPYTHONDIR)
+-XCBPROTO_XCBPYTHONDIR=`$PKG_CONFIG --variable=pythondir xcb-proto`
++XCBPROTO_XCBPYTHONDIR=$PKG_CONFIG_SYSROOT_DIR/`$PKG_CONFIG --variable=pythondir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBPYTHONDIR)
+ AC_SUBST(XCBPROTO_XCBPYTHONDIR)
+