aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-12-21 01:42:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-22 16:08:44 +0000
commitcad52140997e86c6fee4938369dfce21767f1a63 (patch)
tree2b0c910a70d221a1a90fec2f3b7736570570ea3d /meta/recipes-graphics/xorg-lib/libxcb
parent4fe048b7b32eb3d20a43171b83e8ad2037192d34 (diff)
downloadopenembedded-core-contrib-cad52140997e86c6fee4938369dfce21767f1a63.tar.gz
libxcb: Add a workaround for gcc5 bug on mips
This fixes build failure for libxcb on mips Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb/gcc-mips-pr68302-mips-workaround.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb/gcc-mips-pr68302-mips-workaround.patch b/meta/recipes-graphics/xorg-lib/libxcb/gcc-mips-pr68302-mips-workaround.patch
new file mode 100644
index 0000000000..698d038f90
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb/gcc-mips-pr68302-mips-workaround.patch
@@ -0,0 +1,22 @@
+Reduce debug info for xcb.c since on mips we run into a gcc5 bug
+
+https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68302
+
+This patch is a workaround to get past the gcc bug until its resolved.
+it should have minimal impact on libxcb while make it work.
+
+Upstream-Status: Inappropriate [OE-Specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: libxcb-1.11.1/src/Makefile.am
+===================================================================
+--- libxcb-1.11.1.orig/src/Makefile.am
++++ libxcb-1.11.1/src/Makefile.am
+@@ -188,6 +188,7 @@ EXTSOURCES += xkb.c
+ if BUILD_XKB
+ lib_LTLIBRARIES += libxcb-xkb.la
+ libxcb_xkb_la_LDFLAGS = -version-info 1:0:0 -no-undefined
++CFLAGS += -g1
+ libxcb_xkb_la_LIBADD = $(XCB_LIBS)
+ nodist_libxcb_xkb_la_SOURCES = xkb.c xkb.h
+ endif