aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-font
diff options
context:
space:
mode:
authorRichard Tollerton <rich.tollerton@ni.com>2014-12-12 13:34:00 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-19 18:08:00 +0000
commitef552b95359a2914f80499bbf3ec7d6d40beaaa8 (patch)
tree609f0edff059c4fc17964876fc30b6c5ed649bee /meta/recipes-graphics/xorg-font
parent244cb9b5c39aba48773f14b708ffe6922071093f (diff)
downloadopenembedded-core-contrib-ef552b95359a2914f80499bbf3ec7d6d40beaaa8.tar.gz
font-util: Fix incorrect PKG_CONFIG_PATH
PKG_CONFIG_PATH always defaults to /usr/lib/pkgconfig, and the host /usr/lib/pkgconfig is always checked as a fallback; however, PKG_CONFIG_PATH is currently (incorrectly) set to /usr/lib/pkg-config in the sysroot, which doesn't exist. On host distros where the font encoding maps are stored under a different path than OE, this will break font builds, because ucs2any will attempt to read the sysroot's encoding maps with the host paths. (From OE-Core rev: 89a29a3ad0742cd713e739d3d460be7711966679) Signed-off-by: Richard Tollerton <rich.tollerton@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-font')
-rw-r--r--meta/recipes-graphics/xorg-font/font-util_1.3.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-font/font-util_1.3.0.bb b/meta/recipes-graphics/xorg-font/font-util_1.3.0.bb
index 8b42991d1c..cc4258ad7b 100644
--- a/meta/recipes-graphics/xorg-font/font-util_1.3.0.bb
+++ b/meta/recipes-graphics/xorg-font/font-util_1.3.0.bb
@@ -17,7 +17,7 @@ RDEPENDS_${PN}_class-native = "mkfontdir-native mkfontscale-native"
PR = "${INC_PR}.0"
do_configure_prepend() {
- sed -i "s#MAPFILES_PATH=\`pkg-config#MAPFILES_PATH=\`PKG_CONFIG_PATH=\"${STAGING_LIBDIR_NATIVE}/pkg-config\" pkg-config#g" ${S}/fontutil.m4.in
+ sed -i "s#MAPFILES_PATH=\`pkg-config#MAPFILES_PATH=\`PKG_CONFIG_PATH=\"${STAGING_LIBDIR_NATIVE}/pkgconfig\" pkg-config#g" ${S}/fontutil.m4.in
}
BBCLASSEXTEND = "native"