aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-11-23 01:47:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-24 15:12:06 +0000
commit58e600ae3cc955ebe30b2756540404a267c7cb26 (patch)
tree690bfc86e51ea1c3cc08bac7778000c3f520845e /meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
parent1668b4d4f373292ea4d611712ef56148ededfce5 (diff)
downloadopenembedded-core-contrib-58e600ae3cc955ebe30b2756540404a267c7cb26.tar.gz
xf86-video-omapfb: revive driver which actually works and is tested on real devices
* 0006-omapfb-port-to-new-xserver-video-API.patch added to port it to new xserver video API * other patches just updated headers to be able to git am them Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb')
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb b/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
new file mode 100644
index 0000000000..50ce4c2f9c
--- /dev/null
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
@@ -0,0 +1,33 @@
+require xorg-driver-video.inc
+
+SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver"
+
+DESCRIPTION = "omapfb driver supports the basic Texas Instruments OMAP \
+framebuffer."
+
+LICENSE = "MIT-X & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=63e2cbac53863f60e2f43343fb34367f"
+DEPENDS += "virtual/libx11"
+
+SRCREV = "28c006c94e57ea71df11ec4fff79d7ffcfc4860f"
+PR = "${INC_PR}.7"
+PV = "0.1.1+gitr${SRCPV}"
+
+SRC_URI = "git://git.pingu.fi/xf86-video-omapfb;protocol=http \
+ file://0001-Revert-Set-a-large-CRTC-upper-limit-to-not-prune-lar.patch \
+ file://0002-Revert-Set-virtual-size-when-configuring-framebuffer.patch \
+ file://0003-force-plain-mode.patch \
+ file://0004-blacklist-tv-out.patch \
+ file://0005-Attempt-to-fix-VRFB.patch \
+ file://0006-omapfb-port-to-new-xserver-video-API.patch \
+"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF_armv7a = " --enable-neon "
+CFLAGS += " -I${STAGING_INCDIR}/xorg "
+
+# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
+do_compile_prepend_armv7a () {
+ sed -i -e s:fb1:fb2:g ${S}/src/omapfb-xv.c
+}