aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-10-21 04:23:55 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:14:38 +0000
commit3edf08b38b0af93cef0933b061349264dc86d54c (patch)
tree2f99a5328a7663ef410def2023903b2b2d4f230c /meta/recipes-graphics/wayland
parenta3310eb5a447864e82a38cb7852f30c17c0b91bb (diff)
downloadopenembedded-core-contrib-3edf08b38b0af93cef0933b061349264dc86d54c.tar.gz
recipes: add distro_features_check for some packages
* The packages that depends on gtk+3 require any of distro features from ${GTK3DISTROFEATURES} * The packages that depends on virtual/egl, virtual/libgl ... require distro feature 'opengl' Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/wayland')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb4
-rw-r--r--meta/recipes-graphics/wayland/weston_1.8.0.bb4
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 38b78bcd02..fc2e4f80ee 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -11,7 +11,9 @@ do_install() {
install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
}
-inherit allarch update-rc.d
+inherit allarch update-rc.d distro_features_check
+# rdepends on weston which depends on virtual/egl
+REQUIRED_DISTRO_FEATURES = "opengl"
RDEPENDS_${PN} = "weston kbd"
diff --git a/meta/recipes-graphics/wayland/weston_1.8.0.bb b/meta/recipes-graphics/wayland/weston_1.8.0.bb
index 342c604b98..95cf4956da 100644
--- a/meta/recipes-graphics/wayland/weston_1.8.0.bb
+++ b/meta/recipes-graphics/wayland/weston_1.8.0.bb
@@ -16,7 +16,9 @@ SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
SRC_URI[md5sum] = "24cb8a7ed0535b4fc3642643988dab36"
SRC_URI[sha256sum] = "8963e69f328e815cec42c58046c4af721476c7541bb7d9edc71740fada5ad312"
-inherit autotools pkgconfig useradd
+inherit autotools pkgconfig useradd distro_features_check
+# depends on virtual/egl
+REQUIRED_DISTRO_FEATURES = "opengl"
DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
DEPENDS += "wayland libinput virtual/egl pango"