summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2022-03-12 15:10:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-13 12:22:43 +0000
commite3dc3ee5e41caa1691ebdb1c6ed6e51077f9ce7a (patch)
treedd7bba45cfcd735ee25139e0a0c9171f76392f34 /meta/recipes-graphics/wayland
parentcb8b6f7eee4e059bb311330c57068e11bc477366 (diff)
downloadopenembedded-core-contrib-e3dc3ee5e41caa1691ebdb1c6ed6e51077f9ce7a.tar.gz
weston-init: add use-pixman PACKAGECONFIG
Fbdev backend has been deprecated since weston 10.0.0, and it could be replaced by passing --use-pixman to drm backend, add a use-pixman PACKAGECONFIG for convenience. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 8e8c0454be..c34582137d 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -17,6 +17,7 @@ S = "${WORKDIR}"
PACKAGECONFIG ??= ""
PACKAGECONFIG[no-idle-timeout] = ",,"
+PACKAGECONFIG[use-pixman] = ",,"
DEFAULTBACKEND ??= ""
DEFAULTBACKEND:qemuall ?= "drm"
@@ -51,6 +52,10 @@ do_install() {
sed -i -e "/^\[core\]/a idle-time=0" ${D}${sysconfdir}/xdg/weston/weston.ini
fi
+ if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-pixman', 'yes', 'no', d)}" = "yes" ]; then
+ sed -i -e "/^\[core\]/a use-pixman=true" ${D}${sysconfdir}/xdg/weston/weston.ini
+ fi
+
install -dm 755 -o weston -g weston ${D}/home/weston
}