aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-05-22 08:39:38 -0700
committerTim Orling <TicoTimo@gmail.com>2014-05-22 08:39:38 -0700
commit0cb2338890e2e17637a98f11ffa3fe7aed8d4b11 (patch)
treeea6ae9b4d657ae0d97bc9c7d1110304517c8717b /meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch
parent1b82befddc200055ae574985e9a79925987e8b0e (diff)
downloadopenembedded-core-contrib-timo/wayland-weston-1.5.0.tar.gz
weston: upgrade to 1.5.0timo/wayland-weston-1.5.0
* replace 0001-remove-dependence-on-wayland-scanner-flags.patch with disable-wayland-scanner-pkg-check.patch * add make-lcms-configureable.patch (WIP... needs work) = fix for JaMa test-dependencies
Diffstat (limited to 'meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch')
-rw-r--r--meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch b/meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch
new file mode 100644
index 0000000000..817ac70a15
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston/make-lcms-configurable.patch
@@ -0,0 +1,22 @@
+Index: weston-1.5.0/configure.ac
+===================================================================
+--- weston-1.5.0.orig/configure.ac
++++ weston-1.5.0/configure.ac
+@@ -491,8 +491,16 @@ AC_ARG_ENABLE(demo-clients-install,
+ enable_demo_clients_install=no)
+ AM_CONDITIONAL(INSTALL_DEMO_CLIENTS, [test "x$enable_demo_clients_install" = "xyes"])
+
++AC_ARG_ENABLE(lcms,
++ AS_HELP_STRING([--disable-lcms],
++ [disable lcms support]),,
++ enable_lcms=yes)
++
++AS_IF([test "x$enable_lcms" != "no"], [
+ PKG_CHECK_MODULES(LCMS, lcms2,
+- [have_lcms=yes], [have_lcms=no])
++ [have_lcms=yes], [have_lcms=no])],
++ [have_lcms=no])
++
+ if test "x$have_lcms" = xyes; then
+ AC_DEFINE(HAVE_LCMS, 1, [Have lcms support])
+ fi