aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston-init.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-01 17:35:56 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-12 23:31:40 +0000
commite67c7f0998a5a285bd079d2c956bd61457e75077 (patch)
treec8eb348987f2a32c5364f858806430d6714db0e3 /meta/recipes-graphics/wayland/weston-init.bb
parent1cda7afd4173100e4185ee8759f6b2770bc93b72 (diff)
downloadopenembedded-core-contrib-e67c7f0998a5a285bd079d2c956bd61457e75077.tar.gz
weston-init: add a native systemd unit file
Previously weston was started by systemd via a classic init script [YOCTO #5582] Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston-init.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index fc2e4f80ee..653541e3c8 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -1,17 +1,22 @@
-SUMMARY = "Startup script for the Weston Wayland compositor"
+SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
-SRC_URI = "file://init"
+SRC_URI = "file://init \
+ file://weston.service"
S = "${WORKDIR}"
do_install() {
install -d ${D}/${sysconfdir}/init.d
install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}
}
-inherit allarch update-rc.d distro_features_check
+inherit allarch update-rc.d distro_features_check systemd
+
# rdepends on weston which depends on virtual/egl
REQUIRED_DISTRO_FEATURES = "opengl"
@@ -19,3 +24,5 @@ RDEPENDS_${PN} = "weston kbd"
INITSCRIPT_NAME = "weston"
INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
+
+SYSTEMD_SERVICE_${PN} = "weston.service"