aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston-init.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-05-18 13:40:42 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-21 22:21:30 +0100
commit9d745d7c958402fa1d59c9d0267b58a05d7ee4b3 (patch)
treeb45b381b0db0b6ebd1af7c4cb556a0610a393e1b /meta/recipes-graphics/wayland/weston-init.bb
parent6295197adc022445fff01ca5ee75780a4c007d99 (diff)
downloadopenembedded-core-contrib-9d745d7c958402fa1d59c9d0267b58a05d7ee4b3.tar.gz
weston-init: Rework do_install to use install -D option
The install -D allow for the parent directories to be created in a single command line, reducing the code and number of fork during the build. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston-init.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 653541e3c8..4ad62cff2d 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -8,11 +8,8 @@ SRC_URI = "file://init \
S = "${WORKDIR}"
do_install() {
- install -d ${D}/${sysconfdir}/init.d
- install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
-
- install -d ${D}${systemd_system_unitdir}
- install -m0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}
+ install -Dm755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
+ install -Dm0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
}
inherit allarch update-rc.d distro_features_check systemd