aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston-conf.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2018-10-25 05:58:26 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-28 08:31:49 +0000
commit0f43ea8510ae6148a49eb25accac407b6b301b43 (patch)
tree642a8decad7f6c932c737e7579267d3e761fcffb /meta/recipes-graphics/wayland/weston-conf.bb
parented335e201c878ab4518675f57ce0d12cdc60e02e (diff)
downloadopenembedded-core-contrib-0f43ea8510ae6148a49eb25accac407b6b301b43.tar.gz
weston: Split out machine specific configuration
Weston needs to be configured to load the fbdev driver when run on a QEMU system. Other MACHINEs may want to also provider their own configuration as well.. Adding a new RRECOMMEND configuration package will allow this, but avoid installing empty packages/files in the majority case where it is not needed. Add maintainer entry as well. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston-conf.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston-conf.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston-conf.bb b/meta/recipes-graphics/wayland/weston-conf.bb
new file mode 100644
index 0000000000..f52200c46a
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston-conf.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Weston, a Wayland compositor, configuration files"
+HOMEPAGE = "http://wayland.freedesktop.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+CONFFILES_${PN} = "${sysconfdir}/xdg/weston/weston.ini"
+
+FILES_${PN} = "${sysconfdir}/xdg/weston/weston.ini"
+
+PACKAGES = "${PN}"
+
+do_configure[noexec] = '1'
+do_compile[noexec] = '1'
+
+do_install() {
+ :
+}
+
+do_install_qemux86() {
+ mkdir -p ${D}/${sysconfdir}/xdg/weston
+ cat << EOF > ${D}/${sysconfdir}/xdg/weston/weston.ini
+[core]
+backend=fbdev-backend.so
+EOF
+}
+
+do_install_qemux86-64() {
+ mkdir -p ${D}/${sysconfdir}/xdg/weston
+ cat << EOF > ${D}/${sysconfdir}/xdg/weston/weston.ini
+[core]
+backend=fbdev-backend.so
+EOF
+}