aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.5.0.bb
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-05-22 08:31:26 -0700
committerTim Orling <TicoTimo@gmail.com>2014-05-22 08:31:26 -0700
commit1b82befddc200055ae574985e9a79925987e8b0e (patch)
treefd09fc402a3053d62417ef1aa9d953cd60bfeea2 /meta/recipes-graphics/wayland/wayland_1.5.0.bb
parente273301efa0037a13c3a60b4414140364d9c9873 (diff)
downloadopenembedded-core-contrib-1b82befddc200055ae574985e9a79925987e8b0e.tar.gz
wayland: upgrade to 1.5.0
* update disable-macro-checks-not-used-for-scanner.patch = trivial change to non-patched text (+ posix_fallocate) * drop just-scanner.patch, no longer needed
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.5.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.5.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.5.0.bb b/meta/recipes-graphics/wayland/wayland_1.5.0.bb
new file mode 100644
index 0000000000..b1ae59ef13
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.5.0.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Wayland, a protocol between a compositor and clients"
+DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
+as well as a C library implementation of that protocol. The compositor can be \
+a standalone display server running on Linux kernel modesetting and evdev \
+input devices, an X application, or a wayland client itself. The clients can \
+be traditional applications, X servers (rootless or fullscreen) or other \
+display servers."
+HOMEPAGE = "http://wayland.freedesktop.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
+ file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
+
+SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
+SRC_URI[md5sum] = "1d882776b27329b91d2d500b6d66dd1d"
+SRC_URI[sha256sum] = "0069e1e9af888b3e05384380ad8cc6c976ea3e81d08ba19b7675ce1d693a41b5"
+SRC_URI_append_class-native = " \
+ file://disable-macro-checks-not-used-for-scanner.patch \
+ "
+EXTRA_OECONF_class-native = "--disable-documentation --enable-scanner"
+
+inherit autotools pkgconfig
+
+# We need wayland-native for the wayland-scanner utility
+BBCLASSEXTEND = "native"
+
+DEPENDS_class-native = "expat-native libffi-native"
+DEPENDS = "expat libffi wayland-native"
+
+EXTRA_OECONF = "--disable-documentation --disable-scanner"
+
+# Wayland installs a M4 macro for other projects to use, which uses the target
+# pkg-config to find files. Replace pkg-config with pkg-config-native.
+do_install_append_class-native() {
+ sed -e 's,PKG_CHECK_MODULES(.*),,g' \
+ -e 's,$PKG_CONFIG,pkg-config-native,g' \
+ -i ${D}/${datadir}/aclocal/wayland-scanner.m4
+}
+
+sysroot_stage_all_append_class-target () {
+ cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
+}