aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_1.8.1.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-08-09 10:14:59 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-09 09:25:47 +0100
commitdf7f5221a56118da7654476f072c37ae1e75dc50 (patch)
tree03d7c0479ced515bb478322b76475cfcdf786593 /meta/recipes-graphics/wayland/libinput_1.8.1.bb
parent91d1664d66ffd0d3ec06824ff13861faf89ba96a (diff)
downloadopenembedded-core-contrib-df7f5221a56118da7654476f072c37ae1e75dc50.tar.gz
libinput: Upgrade 1.7.3 -> 1.8.1
New feature release, see https://lists.freedesktop.org/archives/wayland-devel/2017-June/034286.html for the major features. This is the last major release to support autotools. Configure flag "--enable-event-gui" changed name. Configure flags no longer default to "auto": explicitly disable the things that were previously automatically disabled. Package the binaries into libinput-bin while being careful with packaging as the main package gets renamed to libinput10. Add patch to fix a race in install. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_1.8.1.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.8.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.8.1.bb b/meta/recipes-graphics/wayland/libinput_1.8.1.bb
new file mode 100644
index 0000000000..f75298b899
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_1.8.1.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Library to handle input devices in Wayland compositors"
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2184aef38ff137ed33ce9a63b9d1eb8f"
+
+DEPENDS = "libevdev udev mtdev"
+
+SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
+ file://touchpad-serial-synaptics-need-to-fake-new-touches-on-TRIPLETAP.patch \
+ file://0001-tools-Fix-race-in-autotools-install.patch \
+"
+
+SRC_URI[md5sum] = "8247f0bb67052ffb272c50c3cb9c5998"
+SRC_URI[sha256sum] = "e3590a9037e561a5791c8bd3b34bfd30fad5cacd8cbefc0d75fafe3a41d07147"
+
+inherit autotools pkgconfig lib_package
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
+PACKAGECONFIG[libwacom] = "--enable-libwacom,--disable-libwacom,libwacom"
+PACKAGECONFIG[gui] = "--enable-debug-gui,--disable-debug-gui,cairo gtk+3"
+
+UDEVDIR = "`pkg-config --variable=udevdir udev`"
+
+EXTRA_OECONF += "--with-udev-dir=${UDEVDIR} --disable-documentation --disable-tests"
+
+# package name changed in 1.8.1 upgrade: make sure package upgrades work
+RPROVIDES_${PN} = "libinput"
+RREPLACES_${PN} = "libinput"
+RCONFLICTS_${PN} = "libinput"