aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/packagegroups
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-09-04 22:58:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 17:37:04 +0100
commita398c96706c119f298f57a929a317fcf8e0f5b92 (patch)
tree7d4e8a2f1516dffa3ebace30f1000daa46f0ea12 /meta/recipes-graphics/packagegroups
parent3b428debe9fdd4c9197f5ee7ab34fc9886f4a3cb (diff)
downloadopenembedded-core-contrib-a398c96706c119f298f57a929a317fcf8e0f5b92.tar.gz
packagegroup-core-x11: split machine specific parts to separate recipe packagegroup-core-x11-server
* add new packagegroup-core-x11-server to SIGGEN_EXCLUDERECIPES_ABISAFE, so that recipes depending on it are not rebuilt after every machine swtich * allows to remove task-x11-server and task-x11 from meta-oe without loosing any functionality * be carefull with default XSERVER value which does not have xf86-input-mouse and xf86-input-keyboard) * VIRTUAL-RUNTIME_xserver_common which defaults to x11-common in oe-core and xserver-common in meta-oe's task-x11 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/packagegroups')
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb24
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb16
2 files changed, 26 insertions, 14 deletions
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
new file mode 100644
index 0000000000..bf39e6316b
--- /dev/null
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+LICENSE = "MIT"
+PR = "r38"
+
+inherit packagegroup
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+PACKAGES = "${PN}"
+
+XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+
+SUMMARY_${PN} = "X11 display server"
+RDEPENDS_${PN} = "\
+ ${XSERVER} \
+ "
+
+# Allow replacing task-x11-server in meta-oe
+RPROVIDES_${PN} = "task-x11-server task-xserver"
+RREPLACES_${PN} = "task-x11-server task-xserver"
+RCONFLICTS_${PN} = "task-x11-server task-xserver"
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
index e306c08ce2..e89df3aaab 100644
--- a/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
@@ -3,15 +3,11 @@
#
LICENSE = "MIT"
-PR = "r37"
+PR = "r38"
inherit packagegroup
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-PACKAGES = "${PN} ${PN}-xserver ${PN}-utils"
-
-XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+PACKAGES = "${PN} ${PN}-utils"
# xserver-common, x11-common
VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
@@ -25,11 +21,6 @@ RDEPENDS_${PN} = "\
${PN}-utils \
"
-SUMMARY_${PN}-xserver = "X11 display server"
-RDEPENDS_${PN}-xserver = "\
- ${XSERVER} \
- "
-
SUMMARY_${PN}-utils = "X11 basic utilities and init"
RDEPENDS_${PN}-utils = "\
${VIRTUAL-RUNTIME_xserver_common} \
@@ -44,9 +35,6 @@ RDEPENDS_${PN}-utils = "\
RPROVIDES_${PN} = "task-x11"
RREPLACES_${PN} = "task-x11"
RCONFLICTS_${PN} = "task-x11"
-RPROVIDES_${PN}-xserver = "task-x11-server task-xserver"
-RREPLACES_${PN}-xserver = "task-x11-server"
-RCONFLICTS_${PN}-xserver = "task-x11-server"
RPROVIDES_${PN}-utils = "task-x11-utils"
RREPLACES_${PN}-utils = "task-x11-utils"
RCONFLICTS_${PN}-utils = "task-x11-utils"