aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 22:58:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 17:37:04 +0100
commit3b428debe9fdd4c9197f5ee7ab34fc9886f4a3cb (patch)
tree758a39dd425d2cbba2e8a72a439325eabadcc3ea /meta/recipes-graphics/packagegroups
parentca8ff97080b635ff9ba21c2a2f6d33cb211f7a83 (diff)
downloadopenembedded-core-contrib-3b428debe9fdd4c9197f5ee7ab34fc9886f4a3cb.tar.gz
packagegroup-core-x11: add upgrade path from meta-oe task-x11*
This recipe was structured in order to replace task-x11 from meta-oe, which it hopefully can now that a runtime upgrade path is in place. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/packagegroups')
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
index 37045213ad..e306c08ce2 100644
--- a/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
@@ -3,7 +3,7 @@
#
LICENSE = "MIT"
-PR = "r36"
+PR = "r37"
inherit packagegroup
@@ -39,3 +39,14 @@ RDEPENDS_${PN}-utils = "\
xset \
xrandr \
"
+
+# Allow replacing task-x11* in meta-oe
+RPROVIDES_${PN} = "task-x11"
+RREPLACES_${PN} = "task-x11"
+RCONFLICTS_${PN} = "task-x11"
+RPROVIDES_${PN}-xserver = "task-x11-server task-xserver"
+RREPLACES_${PN}-xserver = "task-x11-server"
+RCONFLICTS_${PN}-xserver = "task-x11-server"
+RPROVIDES_${PN}-utils = "task-x11-utils"
+RREPLACES_${PN}-utils = "task-x11-utils"
+RCONFLICTS_${PN}-utils = "task-x11-utils"