aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/packagegroups
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-23 21:56:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-24 20:07:59 +0000
commit285c7577813cf75a3b554f8a5d6d7ba002127ef4 (patch)
treea8064a8bd181e9aa201f419c7e1d76ecc50ed916 /meta/recipes-graphics/packagegroups
parent22429cdf79ed952072707a929643c7386fa7e056 (diff)
downloadopenembedded-core-contrib-285c7577813cf75a3b554f8a5d6d7ba002127ef4.tar.gz
packagegroup-core-x11-xserver: Add XSERVERCODECS variable
At present its hard for the system to provide extra x11 hardware codecs. We could lump them in with the XSERVER variable but this is suboptimal as in some use cases the user might not want to include them in some images. With this patch we keep our options open about separating usage of the two in the future. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/packagegroups')
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
index fd6ed42cbe..3c70c530d9 100644
--- a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
@@ -10,10 +10,12 @@ inherit packagegroup
PACKAGE_ARCH = "${MACHINE_ARCH}"
XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+XSERVERCODECS ?= ""
SUMMARY_${PN} = "X11 display server"
RDEPENDS_${PN} = "\
${XSERVER} \
+ ${XSERVERCODECS} \
"
# Allow replacing task-x11-server in meta-oe